PDA

View Full Version : G750JW GPU not detected right - after mb replaced, solved for now (thanks Dreamonic)



NLAIV
01-12-2018, 04:19 AM
Hi,

Few months back my JWs motherboard died, and after replacing it, the dedicated gpu was no longer detected right. I know that the gtx765m is fully functional, but not seen right in any test or program that lists the hardware, except aida64. Also, deviceID/instanceID seem to point to the right gpu, but still nvidia drivers refuse the installation.
Searching through internet did not yield too much information, at least for me. But I am quite sure this has something to do with bios versions between G750J models. The current bios is from G750JH.206. Shouldn't the right one for this laptop be G750JW.210? Asus easyflash through bios gives the error about wrong model, and another suggested method from here and from some other forums, afudos seemed to hang on flash command, not doing anything.

Any ideas how to get the laptop working properly? Help flashing the right bios to the mlb?
Or do I just have a "powerful" workstation type laptop with abysmal battery life?

Attached image should have everything I managed to dig out about bios and gpu...

Dreamonic
01-12-2018, 04:50 AM
Are you certain the MB you got was a JW model? What does the stamp show it as on the PCB?

It could be A) the MB you got was a JW model with the JH BIOS flashed on or B) the MB you got was indeed the JH model and which requires custom NV drivers to get around the Subsystem IDs being incorrect for that model of GPU (notebook model/series) configuration as NV drivers are trying to match this as well.

More information is requested here.

NLAIV
01-12-2018, 06:11 AM
Motherboards I have are identical, both marked as:

G750JW Main board
rev. 2.1.
PCB made in china...

Differences are that original is dead, no life sings other than charging light no matter what I tried, and current seems to have JH206 bios in it, thus rendering the gpu unusable?

Dreamonic
01-12-2018, 07:21 AM
Then it looks like someone used the wrong BIOS image for your replacement MB. I have not seen a JH BIOS working on a JW MB before but I already knew it was possible due to the fact both notebooks don't support Optimus. So it's easier for a different GPU to be used with an unsupported notebook configuration of the same series of model. It just comes down to the drivers not installing.

Anyway,

You have 3 options available at this time.

Now I haven't attempted doing a recovery exactly like this one, so I can't say if forcing the JW BIOS to flash with a data mismatch error (because there will be one since there are 2 different BIOS images) that you'll POST after the flash, even though you'd be flashing the correct one instead. Using SW to do that would likely result in a brick due to a verification signature check failing at the end (possibly). This means a HW programmer would be the way to correct it without taking that risk of potentially having down time with the notebook should you be unable to boot afterwards. If it does work, then it means you can install your GPU drivers without having to modify them.

The other method you can try is with the BIOS recovery tool, specifically Easy Flash Utility and the key combo with the correct BIOS placed on a USB flash drive (formatted as FAT32) procedure. This process requires the notebook be turned off first, proper BIOS image copied to the root of the USB flash drive with it plugged in. Then HOLD the CTRL+HOME keys down together, then press the power button and remain holding just the CTRL+HOME keys down until you are greeted by the Easy Flash Utility screen. At this point, let go. It should begin flashing and power cycle on its own after it's complete. This may work or it could shutdown during the flashing process and still have to be recovered with a HW programmer. This is safer to do than the first option because the BIOS recovery procedure is set to force flash without security measures like specific register range write protections being enabled.

The other option which isn't risky at all, is modifying your NVIDIA drivers INF to work with the unsupported MB BIOS and GPU combo, specifically the nvami.inf file located in your "C:\NVIDIA\DisplayDriver\xxx.xx\Win10_64\Internatio nal\Display.Driver" folder. After modification you can then install the NVIDIA drivers for your 765M GPU successfully. I have created a guide about how to do this here (http://voltground.com/haven/threads/36/) if you wish to try it out.

Basically what the problem is that the NVIDIA display drivers are listed according to vendors/devices(HW IDs)OSes and driver packages. When a notebook model is released for example, by various vendors (we'll use ASUS in this case), NVIDIA will also release a supported driver (with updated IDs) so the installer can DETECT and install the appropriate driver and packages for that HW. Being as your MB BIOS is of a G750JH BIOS which had the 780M GPU, that GPU Device ID can't be found. Instead it detects the 765M Device ID which is paired with a different HW ID for that MB BIOS. So the only way around this is to modify your drivers so they detect the GPU for what it's being listed as according to the Subsystem IDs, which usually is just the Device ID of the currently installed GPU as per your screenshot.

NLAIV
01-12-2018, 03:37 PM
The current mlb was probably pulled out of a g750jh... AFAIK, g750j series with 700m and 800m gpus use the same mlb, without optimus support and with model specific bios.

From the options you gave, I think the first one would give the best results. Tough I do not understad too well, what you mean with hardware programmer... Afudos, asustek easy flash and so-on?

Bios recovery through easyflash utility, and also with winflash from asus support site gave me error mesages, shown in attached pic. CTRL+HOME did not work for me, usually to get to the bios I had to do SHIFT+Reboot > UEFI. (or cold boot and F2)

As for solution, at least temporary, I am going with driver modification, following the guide you linked. Or at least, trying to follow it...

And Thanks for helping me out!

NLAIV
01-12-2018, 04:41 PM
Seems like the driver mod did its job. Previously most 3d apps just crashed straight, but now after the mod below, 765 was capable of running heaven extreme through, giving a score of 418. Not too great, but its WORKING now.

I did hesitate a little before modifying the driver files, as previously I did try to do same for "upgrading" from 765 to 780. At that time, the mod seemed to work fine at first, but as soon as the gpu had something more demanding to render, it crashed the whole pc, requiring reboot to recover... Tough, I'm not ready to give up about that upgrade yet...as shouldn't it just be "drop-in" with JH bios (Tough extensive modifications to heatsink and laptop chassis needed).

Thank you Dreamonic, for helping me out, all the glory from this belongs to you.