PDA

View Full Version : SOLUTION to ENABLING ALL drivers including Sub for Stereo output



XtraArrow
01-13-2018, 09:27 PM
I just recently bought the asus 7.1 centurion and after buying i realized that the sound was terrible as it only USED the front channel for stereo and not the sub. also for games that doesn't support 5.1 or 7.1 it only uses stereo. Here are the steps

1. download EqualizerAPO and configure it to your headset device on popup.
2. download peace equalizer for equalizerAPO and install.
3. After both of them are installed, run the peaceUI and click on the Effects button on the right hand side
4. When the effects menu pops up turn the "upmix" to on and it will utilize all drivers for stereo

5. IF you want the Subwoofer to work properly, click on "subwoofer" on the right hand side. Navigate to the equalizer and underneath the eqaulizer @ 60hz, click on the filter box and choose "Low Pass Filter"

IF you don't have 60hz, edit the frequencies in the equalizer and change it to 60hz although you can experiment with this as i do NOT know what sounds best for this subwoofer.
Short and quick but let me know what you guys think.

Mollari
01-20-2018, 12:37 PM
Thank you very much for that great information.

This is the tool I was looking for. With the integrated channel routing sounds from the rear are sounding as they should. The per-channel equalizer is awesome!!!

And with my special adaptor, i do not need the asus box anymore, saved 2 USB Ports and made my integrated 7.1 soundcard useful again...

XtraArrow
01-21-2018, 12:04 AM
Thank you very much for that great information.

This is the tool I was looking for. With the integrated channel routing sounds from the rear are sounding as they should. The per-channel equalizer is awesome!!!

And with my special adaptor, i do not need the asus box anymore, saved 2 USB Ports and made my integrated 7.1 soundcard useful again...

Glad it worked for you pal, if we could just get the Subwoofer to work for all channels then it would be perfect!

toronto699
01-21-2018, 12:21 AM
Could You Please Post Links For The Apps Please

Mollari
01-23-2018, 10:08 AM
Glad it worked for you pal, if we could just get the Subwoofer to work for all channels then it would be perfect!

Yeah, you can activate the Subwoofer for all channels by rerouting all channels to the LFE/SUB channel. It is working on my machine and sounds perfect with a proper equalizer setting for that LFE/SUB channel

XtraArrow
01-23-2018, 02:28 PM
Yeah, you can activate the Subwoofer for all channels by rerouting all channels to the LFE/SUB channel. It is working on my machine and sounds perfect with a proper equalizer setting for that LFE/SUB channel

Thank you, I've edited the OP with brief instructions on how to add a Low pass to make the subwoofer work as it should.

Mollari
01-30-2018, 12:15 PM
Here is a screenshot of the "Effects Panel" for the channel configuration

71033

XtraArrow
01-30-2018, 01:03 PM
Here is a screenshot of the "Effects Panel" for the channel configuration

71033

Nice, what I did is disable subwoofer for the front channels as the fronts provide enough bass as it is so I let the subwoofers work for the rear and side as they only have 20mm drivers. On games like pubg that don't support 7.1 the sides and rears just don't sound as they should. This also fixes the tinny issue people were having. I might create a new thread with a profile for pubg that I created.

Skofgaard
01-30-2018, 09:56 PM
Nice, what I did is disable subwoofer for the front channels as the fronts provide enough bass as it is so I let the subwoofers work for the rear and side as they only have 20mm drivers. On games like pubg that don't support 7.1 the sides and rears just don't sound as they should. This also fixes the tinny issue people were having. I might create a new thread with a profile for pubg that I created.

XtraArrow:
I don't know if it's me who's doing something wrong, but I can't seem to have any success with the Equalizer APO software. Could you perhaps upload a picture of your equalizer settings and the effects windows? It would be greatly appreciated.

XtraArrow
01-30-2018, 10:33 PM
XtraArrow:
I don't know if it's me who's doing something wrong, but I can't seem to have any success with the Equalizer APO software. Could you perhaps upload a picture of your equalizer settings and the effects windows? It would be greatly appreciated.

I can help you mate, are you able to elaborate on what you mean when you say the software isn't working for you?

Skofgaard
01-31-2018, 06:43 PM
I can help you mate, are you able to elaborate on what you mean when you say the software isn't working for you?

Well you just wrote at some point that your 7.1 is amazing with the Equalizer APO software. I have been tinkering with it and i can't find any proper settings that will blow me away, and frankly im a bit confused with the different equalizer settings for "All", "Subwoofer", "Front", "Side" and "Rear". Does that mean i need different equalizer settings for the different speakers? Furthermore, you can set frequencies, quality and filter for each slider, im not an audio expert so these things don't mean quite a lot to me.

My current equalizer settings:

For "All" speakers:
Slider 1 = 10Hz, gain = 17.5dB, filter = high shelf filter
Slider 2 = 21Hz, gain = 11dB, filter = high shelf filter
Slider 3 = 42Hz, gain = 12dB, filter = peakfilter
Slider 4 = 83Hz, gain = 10dB, filter = peakfilter
Slider 5 = 166Hz, gain = 5.5dB, filter = peakfilter
Slider 6 = 333Hz, gain = 1.5dB, filter = peakfilter
Slider 7 = 577Hz, gain = -1dB, filter = peakfilter
Slider 8 = 1000Hz, gain = -3dB, filter = peakfilter
Slider 9 = 2000Hz, gain = -6.5dB, filter = low shelf filter
Slider 10 = 4000Hz, gain = -4.5dB, filter = low shelf filter
Slider 11 = 8000Hz, gain = 0dB, filter = peakfilter
Slider 12 = 16000Hz, gain = 13dB, filter = high shelf filter
Slider 13 = 18000Hz, gain = 16dB, filter = high shelf filter

The "Subwoofer", "Front", "Side" and "Rear" equalizers are all flat at 0dB with peakfilters

I have done the channel routing like this.

L -> L
R-> R
C-> C
Sub -> C + Sub + RL + RR + SL + SR
RL -> RL
RR -> RR
SL -> SL
SR -> SR

Futher settings:
Bass gain = +5dB and target = Subwoofer.

Spatial setup = 7.1

Pre Amplifying = -30 dB

Also, do you run the Asus ROG Sonic Studio in the background at the same time as your Equalizer APO?

Any inputs are greatly appreciated, as i think that the headphones have great potential, it's just a damn shame that the firmware doesn't utilize them properly.

XtraArrow
01-31-2018, 11:03 PM
Well you just wrote at some point that your 7.1 is amazing with the Equalizer APO software. I have been tinkering with it and i can't find any proper settings that will blow me away, and frankly im a bit confused with the different equalizer settings for "All", "Subwoofer", "Front", "Side" and "Rear". Does that mean i need different equalizer settings for the different speakers? Furthermore, you can set frequencies, quality and filter for each slider, im not an audio expert so these things don't mean quite a lot to me.

My current equalizer settings:

For "All" speakers:
Slider 1 = 10Hz, gain = 17.5dB, filter = high shelf filter
Slider 2 = 21Hz, gain = 11dB, filter = high shelf filter
Slider 3 = 42Hz, gain = 12dB, filter = peakfilter
Slider 4 = 83Hz, gain = 10dB, filter = peakfilter
Slider 5 = 166Hz, gain = 5.5dB, filter = peakfilter
Slider 6 = 333Hz, gain = 1.5dB, filter = peakfilter
Slider 7 = 577Hz, gain = -1dB, filter = peakfilter
Slider 8 = 1000Hz, gain = -3dB, filter = peakfilter
Slider 9 = 2000Hz, gain = -6.5dB, filter = low shelf filter
Slider 10 = 4000Hz, gain = -4.5dB, filter = low shelf filter
Slider 11 = 8000Hz, gain = 0dB, filter = peakfilter
Slider 12 = 16000Hz, gain = 13dB, filter = high shelf filter
Slider 13 = 18000Hz, gain = 16dB, filter = high shelf filter

The "Subwoofer", "Front", "Side" and "Rear" equalizers are all flat at 0dB with peakfilters

I have done the channel routing like this.

L -> L
R-> R
C-> C
Sub -> C + Sub + RL + RR + SL + SR
RL -> RL
RR -> RR
SL -> SL
SR -> SR

Futher settings:
Bass gain = +5dB and target = Subwoofer.

Spatial setup = 7.1

Pre Amplifying = -30 dB

Also, do you run the Asus ROG Sonic Studio in the background at the same time as your Equalizer APO?

Any inputs are greatly appreciated, as i think that the headphones have great potential, it's just a damn shame that the firmware doesn't utilize them properly.

I'm no audio expert either mate. On the speaker selection, Say you click "subwoofer" the equalizer settings only apply to that speaker, once you select another speaker it'll use its own equalizer if that makes any sense. Let me say, "mind blowing" sound is of course different to all of us as we hear it in differnt ways but i'll link you my profile, i'm also tweaking it constantly to try make it sound better but AGAIN, i'm no were near an audio expert and i barely know what most features mean in the software. http://www99.zippyshare.com/v/eFRxUExG/file.html (http://www52.zippyshare.com/v/4wRhVe0R/file.html) Unzip the .peace file and place it here "C:\Program Files\EqualizerAPO\config" all my speakers are 50% on sound studio except subwoofer on 65%. Let me know how it is for you.

ALSO: On your Audio HUB, Enable the Spectrum and put it to the gaming mode, top left option. this makes it sound a lot better

Archeades
03-24-2018, 09:27 PM
I'm no audio expert either mate. On the speaker selection, Say you click "subwoofer" the equalizer settings only apply to that speaker, once you select another speaker it'll use its own equalizer if that makes any sense. Let me say, "mind blowing" sound is of course different to all of us as we hear it in differnt ways but i'll link you my profile, i'm also tweaking it constantly to try make it sound better but AGAIN, i'm no were near an audio expert and i barely know what most features mean in the software. http://www99.zippyshare.com/v/eFRxUExG/file.html (http://www52.zippyshare.com/v/4wRhVe0R/file.html) Unzip the .peace file and place it here "C:\Program Files\EqualizerAPO\config" all my speakers are 50% on sound studio except subwoofer on 65%. Let me know how it is for you.

ALSO: On your Audio HUB, Enable the Spectrum and put it to the gaming mode, top left option. this makes it sound a lot better

So Ive noticed that with this OBS and Peace installed that it will stop the Surround sound function in game unless Im missing a setting in Peace. I lose the Center, rear, and sub channel but never had sub channel cept in Dark souls so that doesnt really matter.

As far as music this is great and makes music a fulfilling audio joy, but again trying to do music while playing a game you lose the sounds youd normally get for surround.... Not that it really really matters since you wouldnt have music on for when you really need the surround, its just kinda nice to have while playing.

Anyway if you know of a setting Im missing to get this working correctly please let me know.

quattroboy
03-26-2018, 03:08 PM
Well, I just wanted to say thanks to the OP for this thread!

Why ASUS don't ship the Centurions with the ability to EQ each channel individually in the first place, is something of a mystery.