PDA

View Full Version : G751JM Battery indicator blinking orange and green but the problem is weird



Laenthor
01-23-2018, 02:39 AM
I have a G751JM Asus Laptop (it's 3 years old now) and for a while I've been having a couple of specific problems. I could fix most of them myself but after looking for hours on the internet I cannot find a solution to this one. You're gonna have to listen to a little story first.

As you might know this laptop doesn't have a user-removable battery, so when mine died back in September I had to... take some radical measures...
Anyway, I bought a replacement battery and it worked fine until late December. What was happening is that when the battery reaches near 97%, Windows tells me that it is still charging, but when I look in detail, nothing is charging (the battery hardware force-stops the charge). Force closing the computer fixes the problem until I put it in sleep mode for a while when the charger is plugged in. Now this wouldn't be so bad of an issue if only Windows didn't stop telling me how much battery I had left after the led starts blinking! I fixed the problem for about 4 days by calibrating the battery (fully draining it to around 5% and recharging it).

Now if I can't fix this problem for good I don't care that much because I only need this laptop for about 1 more year and I plan on saving for another desktop PC later. I only want to pinpoint the issue and this is what I've figured out:

-The battery works completely fine (maybe a bit used but still well above 98% health). It does not become hot and takes about 3.5 to 4 hours do fully drain like a normal battery should.
-The charger works fine (tested on another model my friend has).
-The blinking led only comes out after hours of inactivity (the amount is very vague), either in sleep mode or fully shut down. After it does, the only way to fix it is to reset the circuits (hold the power button for 10 seconds). Closing it normally doesn't fix the led.
-It is not Windows because the same symptoms happen when the computer is completely off.
-I know what the orange/green light means: an error in the charging circuits though it can be false positive.

What I don't understand is:

-Why Windows continues to charge even after detecting that the battery is at 100% (because yes the wear level varies with each reboot).
-Why it happens even when it's fully closed
-Why only a hard reset can fix it for an instant.


If someone can help me please do so, if you can't, well speculate with me! This is also the last time I ever will buy Asus products; non-user-removable batteries what the hell?!

Edit: Okay so having a mini heart attack right now. Windows just freaked out and told me it couldn't detect the battery, however I can remove the charger and it works just fine (I just have no indication on what battery % is left). The fans also just went to max (first time this happened since I bought this laptop), but the battery is at a normal temperature. Since this forum is broken and I can't send any pictures, let's just say that the battery service says that the battery is not detected, the indicator in the parameters tells me it's full and the battery checker program tells me stuff that doesn't make any sense (mWh in the billions). I will restart my computer and I will tell the results tomorow. This is getting troublesome quickly...

Laenthor
02-01-2018, 08:46 PM
Since no one seems to know an answer, here's an update:

I tried recalibrating the battery today because the same issue reappeared after not even 2 weeks. I used it all day, unplugged, and when it got to around 29%, it unexpectedly shutdown. My conclusion is that one of the 4 battery cells are faulty and it was the one causing the laptop hardware to freak out. I believe it is now completely dead (shame that this battery barely lasted 4 months...), but I still have the 3 other cells which seem to work fine.

The problem will persist over and over again, but the mystery will remain unsolved... Unless someone actually wants to try and reply to me!