PDA

View Full Version : Asus G750JW - Flickering Screen (Loose Contact?)



fschoenfeldt
02-12-2018, 07:06 AM
Hey guys,

for like a month or so I am sometimes having the issue of a flickering screen (display wildly going blue/black) and also sometimes the display doesnt work at all. This problem seems to be a hardware issue, as this is present in boot aswell. I guess it is a loose contact or - if even worse - my graphics card is broken.

Has anyone else experienced such issues?

Cheers x

scrufy
02-18-2018, 07:39 AM
There is a multi conductor cable with connectors between the mb and the screen. You could have just a broken wire on it after a lot of use opening/closing the lid. I replaced the screen on my g751jy and it looked easily damaged the way they snaked it through by the hinge. Connector could also be a bit loose on one end. Hoping for the best of course. Its not difficult to get to but takes a little patience and they are available on ebay.
it has about 20 wires like a ribbon cable but individual wires in this case.
gl and I hope thats all it is and not anything non replacable card related.
Try an external monitor to test if its the card.

fschoenfeldt
02-19-2018, 03:02 PM
There is a multi conductor cable with connectors between the mb and the screen. You could have just a broken wire on it after a lot of use opening/closing the lid. I replaced the screen on my g751jy and it looked easily damaged the way they snaked it through by the hinge. Connector could also be a bit loose on one end. Hoping for the best of course. Its not difficult to get to but takes a little patience and they are available on ebay.
it has about 20 wires like a ribbon cable but individual wires in this case.
gl and I hope thats all it is and not anything non replacable card related.
Try an external monitor to test if its the card.

First off: Thank you! :)

On external monitor, I havent had any issues so far... But sometimes, the whole system freezes (so far only when I play Heroes of the Storm). What do you think?

fschoenfeldt
03-09-2018, 08:14 AM
So yeah.. today my G750JW screen was black again, so I tried to re-plug the cable on the display and on the mainboard. Didn't help. I will try getting a replacement cable and report back if that helped.

Peace x

fschoenfeldt
03-09-2018, 08:12 PM
Little update: I found out that I always plugged out the webcam cable and not the screen cable. So I double checked both ends of the screen connection and the screen doesn't turn on anymore. External monitor works so far.

Will order a replacement cable and report back if that helped.

EDIT: So I plugged in a HDMI cable and suddenly, my screen went on again. --I found out that if I tap at the place where the screen connector to the mainboard sits under, the screen goes on. Seems like a loose contact of the connection to the mainboard itself.