Search:

Type: Posts; User: quattroboy

Search: Search took 0.00 seconds.

  1. HI Scone. I just ran the updater, but it...

    HI Scone.

    I just ran the updater, but it reported that, "this update is not applicable to your graphics card" :(
  2. Thanks. I'm going to try that now. Appreciate the...

    Thanks. I'm going to try that now. Appreciate the help guys. :)
  3. Checked that. Plugged each monitor power into its...

    Checked that. Plugged each monitor power into its own dedicated wall outlet. Still happens. Just sitting reading a forum and one monitor just turned off and back on again.

    I'm at my wits end. :(
  4. Hi Xeroist. Thanks for the suggestion. I hadn't...

    Hi Xeroist. Thanks for the suggestion. I hadn't thought of that. They all plugged into a large multiple power outlet along with lots of other peripherals. Perhaps the power is limited?

    I'll plug...
  5. Desperate for any ideas please :)

    Desperate for any ideas please :)
  6. Intermittent problem with triple monitors: ROG SWIFT PG27VQ

    Hi folks,

    I recently purchased three ROG SWIFT PG27VQ 27" monitors and they are running off a Gigabyte water-cooled 2080ti on a ROG Maximus XI Hero mobo with a water-cooled i7 9700K @5.1GHz...
  7. Sticky: Hi, I downloaded this file but it fails to...

    Hi,

    I downloaded this file but it fails to update?

    Edit: Fixed. You must download all three items and place them in the same folder before running the exe. :)
  8. Replies
    6
    Views
    1,815

    Hi and thanks for the reply. This is really...

    Hi and thanks for the reply.

    This is really weird. Yes, the 7.1 light is on. I am seeing all channels working within Sonic Studio, when I play a game or even watch youtube or listen to music,...
  9. Replies
    6
    Views
    1,815

    MY Centurions are H9 serial number. I can get all...

    MY Centurions are H9 serial number. I can get all the channels to work and also use the Peace EQ APO. Installed the ASUS software and latest beta whatnot, configured 7.1 in windows working fine. In...
  10. Well, I just wanted to say thanks to the OP for...

    Well, I just wanted to say thanks to the OP for this thread!

    Why ASUS don't ship the Centurions with the ability to EQ each channel individually in the first place, is something of a mystery.
  11. Thanks :)

    Thanks :)
  12. Replies
    0
    Views
    645

    A question regarding the ROG amplifier

    Hi again. I have been discussing my new ROG Centurions on the iRacing forums and someone using the Strix 7.1 headset, stated that both use the same headphone amp. However, in all the official...
  13. Hi. I looked in my file and those two lines...

    Hi.

    I looked in my file and those two lines were not in there.

    Is it ok to copy the text into the file from *this thread?

    Cheers.*
  14. Thanks :)

    Thanks :)
  15. How do I register my ROG Centurions on ASUS website? [Resoved]

    Hi folks,

    Trying to register my Centurions on the ASUS product registration page, but the product is not listed in the drop down menu.

    Is the warranty still valid if I cannot register them?
    ...
  16. Replies
    4
    Views
    1,634

    We really need a low frequency crossover for...

    We really need a low frequency crossover for games that donít send out 7.1

    I canít believe this has been an issue for so long. I only just bought my Centurions this week. Rather dismayed to now...
  17. Replies
    129
    Views
    31,970

    Hi folks. I just purchased Centurions on...

    Hi folks.

    I just purchased Centurions on Monday and after much tuning, I was dismayed to discover the Sub Channel not being used at all.

    I contacted the Sound Developer at iRacing and...
Results 1 to 17 of 17