Search:

Type: Posts; User: SpectralAngel

Page 1 of 2 1 2

Search: Search took 0.00 seconds.

  1. Replies
    29
    Views
    12,888

    I received the new PSU a few days ago (importing...

    I received the new PSU a few days ago (importing stuff yourself sucks big time) along with my new SSD.
    The videocard IS faulty, now it just takes a bit longer to show the issue, it let me boot...
  2. Replies
    29
    Views
    12,888

    XFX costumer support has contacted me and told me...

    XFX costumer support has contacted me and told me the new psu should correct the issue, otherwise they are willing to RMA the card or that i seek an exchange from Amazon.
  3. Replies
    29
    Views
    12,888

    Haha poor psu, burnt that way! I just hope the...

    Haha poor psu, burnt that way! I just hope the new psu be able to fix the issue, I wont really like to rma
  4. Replies
    29
    Views
    12,888

    Ok while i wait for XFX to answer, i am getting...

    Ok while i wait for XFX to answer, i am getting this Corsair PSU delivered, it must be able to drive the card no matter what.
  5. Replies
    29
    Views
    12,888

    The 700W unit has 2 12 volt rails that run 25A...

    The 700W unit has 2 12 volt rails that run 25A each one, is it still not enough, I am reluctant to buy a new PSU if the card is faulty, but if i get enough feed back as if the PSU is not enough I...
  6. Replies
    29
    Views
    12,888

    My OCZ is almost 2 years old, his 850 is like a...

    My OCZ is almost 2 years old, his 850 is like a year old, so basically that rules out the bad psu, filling costumer support at xfx now
  7. Replies
    29
    Views
    12,888

    no, he has a gigabyte 890fx, and I am starting to...

    no, he has a gigabyte 890fx, and I am starting to think is a bad card, too
  8. Replies
    29
    Views
    12,888

    I has a 8pin and a 6pin and yes i connected both...

    I has a 8pin and a 6pin and yes i connected both of them, tried the card 4 times and did the same thing each time, a few seconds of output, then no signal, is it really underpowered?
  9. Replies
    29
    Views
    12,888

    An update, I took the videocard to a friends...

    An update, I took the videocard to a friends house to rule out psu problems. We tested the card on his system.

    my friend has a Rosewill RS850 and we plugged the card. The card posted and, then the...
  10. Replies
    29
    Views
    12,888

    I am using BIOS revision 1101, ill flash 1301 or...

    I am using BIOS revision 1101, ill flash 1301 or whatever is current to test again the videocard and see if it makes any difference
  11. Replies
    29
    Views
    12,888

    Oh, no I am not that crazy, yet. However I...

    Oh, no I am not that crazy, yet. However I suspect its not delivering enough power to the card
  12. Replies
    29
    Views
    12,888

    Already tried with cmos reset from rc poster,...

    Already tried with cmos reset from rc poster, resulted on that brief Asus logo showing for just a second, starting to believe its the psu...
  13. Replies
    29
    Views
    12,888

    No offense taken even after assembling many...

    No offense taken even after assembling many systems I forget the pcie connectors from time to time, however this time evrything was correctly seated and plugged and the fact that it showed the post...
  14. Replies
    29
    Views
    12,888

    Help with HD7970 and Crosshair V

    Today i received my HD7970. I went and swapped the card with my old HD5850, after trying a while i would simply get NO post.

    I got a very short post after a CMOS reset, it showed the motherboard...
  15. Replies
    20
    Views
    15,423

    For some research based advise on Coolers

    A while ago I found a little good website that is specialized on coolers and everything about keeping computers as cool as posible. They even have a nice top chart for both Intel and AMD.
    ...
  16. Replies
    26
    Views
    9,562

    Thanks HiVizMan, now I have just ordered an...

    Thanks HiVizMan, now I have just ordered an FX-8120 to replace the Phenom. I guess the little bugger was tired of 2 and a half year of core Unlocking + OC and since it controlled the memory, well the...
  17. Replies
    26
    Views
    9,562

    Ok it seems I owe Asus an apology, it was the...

    Ok it seems I owe Asus an apology, it was the phenom that died on me, a friend brought his crosshair iv and his x6 and it worked on mine, the x2 did not worked in the crosshair iv
  18. Replies
    26
    Views
    9,562

    This is getting kinda frustrating, Ill not have...

    This is getting kinda frustrating, Ill not have the Sempron until Saturday now.

    Asus Tech Support is now nowhere to be seen. I am desperate, how it comes that a VERY EXPENSIVE piece of electronics...
  19. Replies
    26
    Views
    9,562

    Ill get to a Sempron Am3 processor later this...

    Ill get to a Sempron Am3 processor later this week. I will try reseating the phenom today, and layer will test with the sempron if it does not work, if the sempron works ill simply order a 8120
  20. Replies
    26
    Views
    9,562

    Ok a brand new module yielded no Post so ever, I...

    Ok a brand new module yielded no Post so ever, I guys ill start RMA , I hope they can help me because here in Central America it will be very hard
  21. Replies
    26
    Views
    9,562

    I guess ill buy a cheap module, well not that...

    I guess ill buy a cheap module, well not that cheap, here...
  22. Replies
    26
    Views
    9,562

    A bit mote feedback, got back my spare pc (my dad...

    A bit mote feedback, got back my spare pc (my dad had it), tested it with R.O.G. Connect and it stays at memory detect, what about getting a different RAM, will help?
  23. Replies
    26
    Views
    9,562

    If you check my first post, I just cleaned the...

    If you check my first post, I just cleaned the fan, easily detached without touching anything else in the Frio, so I just removed it from the fan controller and cleaned it using isopropilic alcohol,...
  24. Replies
    26
    Views
    9,562

    Unfortunately, my motherboard did not POST after...

    Unfortunately, my motherboard did not POST after trying all of the above. I guess I must be just out of luck. Well I don't know what else to do.

    P.S. Sorry about the grammar writing from my smart...
  25. Replies
    26
    Views
    9,562

    Yes, I read the same thing on the other thread,...

    Yes, I read the same thing on the other thread, however it was like 1:00 a. m. and doing that means disarming the Armor+, and unscrewing the Thermaltake Frio, kinda. It takes like one hour just to...
Results 1 to 25 of 36
Page 1 of 2 1 2