Search:

Type: Posts; User: CuRle

Search: Search took 0.00 seconds.

  1. Replies
    7
    Views
    2,120

    My motherboard was returned, last week, and is...

    My motherboard was returned, last week, and is now working. A great relief to finally have my PC working again!

    Thank you for your help, Bahz.
  2. Replies
    7
    Views
    2,120

    I've still not gotten a response. It's been...

    I've still not gotten a response.

    It's been over two weeks, this is pathetic.
  3. Replies
    7
    Views
    2,120

    Thank you, both. PM sent.

    Thank you, both.

    PM sent.
  4. Replies
    7
    Views
    2,120

    Can I please get some help with my RMA

    I'm sure others don't like seeing the forum clogged up with threads like this, so my apologies, however spare a though for someone with a dead $1,000(AUD) motherboard.

    I submitted an RMA request...
  5. Replies
    12
    Views
    4,334

    I submitted an RMA request to ASUS, last weekend,...

    I submitted an RMA request to ASUS, last weekend, but still haven't heard from them.
  6. Replies
    12
    Views
    4,334

    I tested my PSU on another PC (just the CPU and...

    I tested my PSU on another PC (just the CPU and 24-pin, so I could get the PC to post), PSU seems fine.

    Have submitted RMA requests for both the CPU and motherboard.
  7. Replies
    12
    Views
    4,334

    RMA process is not something I'm looking forward...

    RMA process is not something I'm looking forward to. I've never had to RMA anything, but I imagine it'll be at least two weeks before my very expensive paperweight is a functional PC, again.

    I...
  8. Replies
    12
    Views
    4,334

    Just checked it. It's reading 3.15v.

    Just checked it. It's reading 3.15v.
  9. Replies
    12
    Views
    4,334

    Think my (x99) Rampage V Edition 10 is dead

    Hi there.

    A few night ago, I was using my PC, when it suddenly (instantly) turned off. No freezing or lock up of any kind, just instantly went out.

    Since then, I have not been able to boot....
Results 1 to 9 of 9