Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Aug 2017
    Reputation
    10
    Posts
    5

    GL553VD ROG Gaming Center

    Hi guys, recently had an issue where my rog button not launch gaming center in my GL553VD. So i downloaded the latest posted here, 2.1.4, and uninstalled ROG Gaming Center. After restart, i tried running the installer and nothing happens. It shows the window loading bar for setting up and the visual c++ then everything just closes. As if nothing happened. Can someone help me out here please? I want my gaming center back. Now i dont have any gaming center. I feel empty without it =[

  2. #2
    New ROGer Array
    Join Date
    Aug 2017
    Reputation
    10
    Posts
    5

    Anyone? Please i want my gaming center back. I cant install it as it just closes on its own. Getting really desperate.

  3. #3
    ROG Enthusiast Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    28

    Quote Originally Posted by GDMTPlays View Post
    Anyone? Please i want my gaming center back. I cant install it as it just closes on its own. Getting really desperate.
    i dont own the GL500 Series but i know if that button is not working its most likely program is corrupted or something, For this i would advice u to boot to safe mode 1st then Uninstall the Rog Center than Boot back to original state and install.

    Also download the latest one from here dont try other ones for now they are not tested for ur current model:

    https://www.asus.com/in/Laptops/ROG-...Desk_Download/

  4. #4
    New ROGer Array
    Join Date
    Aug 2017
    Reputation
    10
    Posts
    5

    Alright, il try that. Thank you so much for the response. I was able to uninstall ROG Gaming Center but it wont let me install it for some reason. It just closes after unpacking. I'll try your method a bit and will post back after.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •