Results 1 to 4 of 4

Thread: Bios 1003

  1. #1
    ROG Member Array vidguys PC Specs
    vidguys PC Specs
    MotherboardROG Maximus VIII Hero Alfa
    Processori7-6700K 4.2GHz
    Memory (part number)Corsair 16GB CMD16GX4M2B3000C15
    Graphics Card #1EVGA 1070 FTW
    MonitorAcer 27 inch
    Storage #1WD Black Performance 1TB
    Storage #2HGST Deskstar NAS 4TB
    CPU CoolerArtic Liquid Freezer 120
    CaseZalman Z11 Plus HF
    Power SupplyEVGA 750W 80+ Gold Semi Modular
    Keyboard Logitech G110
    Mouse Inland 07244
    Headset Gear Head
    OS Win 10

    Join Date
    Oct 2016
    Reputation
    10
    Posts
    24

    Bios 1003

    Are there any problems with Bios update 1003? I have a Maximus X Hero WiFi I want to upgrade.

    Thank you in Advance

  2. #2
    ROG Member Array stealth2920 PC Specs
    stealth2920 PC Specs
    Laptop (Model)Self Built
    MotherboardAsus ROG Maximus Hero X
    ProcessorIntel i7 8700K 4.9 gz
    Memory (part number)GSkill Ripjaws 32gb 3200
    Graphics Card #1EVGA Geforce GTX 1070
    Sound CardSound Blaster Z
    Monitor32" LG 144hz Curve
    Storage #1Samsung Evo 850 Pro 256 SSD
    Storage #2Samsung Evo 850 1TB SSD
    CPU CoolerNoctua NH-D15S Tower
    CaseCoolermaster HAF 922
    Power SupplyCoolermaster 1000
    Keyboard Logitech Wireless
    Mouse Razor
    OS Win 10 Pro 64

    Join Date
    Dec 2017
    Reputation
    10
    Posts
    23

    I haven't had any issues at all with that bios. Updated to that as soon as I finished my new build.

  3. #3
    ROG Member Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    19

    Been using this update since release not a single issue.

  4. #4
    ROG Guru: Yellow Belt Array XYchromosone PC Specs
    XYchromosone PC Specs
    MotherboardASUS Maximux XI Extreme [BIOS 1401]
    Processori9 9900KS
    Memory (part number)G.Skill Trident Z RGB CL17 3600MHz 32GB [4x8]
    Graphics Card #1ASUS ROG Strix Gaming GTX 1080Ti 11GB
    MonitorAOC AGON AG271QG 27" 144Hz-165Hz OC
    Storage #1Samsung 970 Pro NVMe 1TB M.2 SSD
    CPU CoolerThermaltake Floe Riing 360 Premium AIO
    CaseFractal Design Define R6 Black
    Power SupplyCorsair AX1600i
    Keyboard RAZER Blackwidow X Tournament Chroma
    Mouse RAZER Lancehead [ambidextrous] Chroma
    Headset Sennheiser RS165 Wireless
    Headset/Speakers Sennheiser CX 100 inner ear headphones
    OS Windows 10 Pro x64 + Ubuntu Studio 19.04
    Network RouterASUS DSL-AC68U on ADSL2+, Technicolor DJA0230TLS Gateway, Netgear Cable Adapter CM450
    XYchromosone's Avatar
    Join Date
    Dec 2015
    Reputation
    30
    Posts
    244

    No problem here so far. Except every time I enter the BIOS I get a message asking if I want to load previous settings [or is it previous profile?]. I'm not certain if the factory set BIOS asked me that or if this 1003 introduced it, and if it's normal or a bug?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •