Results 1 to 10 of 16

Threaded View

  1. #1
    New ROGer Array MonkY PC Specs
    MonkY PC Specs
    MotherboardAsus Maximus X Hero
    Processori7 8700K
    Memory (part number)CMK64GX4M4B3200C16
    Graphics Card #1GTX 1060 6GB
    Monitor40" Samsung 4K
    Storage #1nVM Samsung 960 Evo 500GB
    Storage #2Samsung 850 Evo 500GB
    CPU CoolerNoctua NH-D15
    CaseCooler Master Cosmos II
    Power SupplyCorsair 750W
    Keyboard Dell USB
    Mouse Logitech G502
    Mouse Pad Razer Firefly
    OS Windows 7 Ultimate 64bit
    Network RouterAsus RT-AC86U
    MonkY's Avatar
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    11

    Exclamation Asus Maximus X Hero - USB Problems all over!

    Hello everyone!

    I have just upgraded from my good old trusty Asus Maximus VIII Hero (with a 6700K CPU) to a brand new Asus Maximux X Hero (with a 8700K CPU). It was probably the best motherboard i ever had. Although i used to have a ton (over 20) of USB devices connected to my old Hero VIII, everything worked flawlessly for years!

    After the upgrade, almost nothing works when it comes to USB ports. Even my old beloved Dell Multimedia USB Keyboard... i can't even use it to enter BIOS!!! I can only use it after it boots up in Windows (it's like it doesn't get power untill a driver loads). I have tried a few keyboards, none of them were recognized at boot time, so i couldn't use DEL or F2...

    I have managed to flash the latest 1003 BIOS for Maximus X Hero, hoping there is a fix for USB issues. But nope! I have also did a CMOS reset, unplugged all other USB devices. Still wasn't able to use my keyboard or my mouse (Logitech G502) in BIOS.

    Also, even i only have one mouse and one keyboard connected, at boot time i can see something like this: "USB Controllers: 3 XHCIs / USB Devices: 2 Drives, 4 Keyboards, 3 Mice, 5 Hubs". 4 Keyboards and 3 Mice?!? What in the world? Where does that coming from? I don't even have so many keyboards and mices in my whole house...

    Also, strange things happen to my two USB external HUB's (Anker AH241 USB 3.0 Aluminum 13-Port Hub and Icybox IB-AC6702 USB 3.0 Hub). After booting up and enter Windows, i have to reset both hub's, as some of my devices do not fully work. That never happened with my old Maximus VIII Hero.

    I have tried all drivers (Intel Chipset drivers + USB 3.x drivers) from the official Asus page, and then tried the latest Intel official and un-official drivers. Also i have been using the latest ASMedia ASM2142 USB 3.1 xHCI Controller drivers.

    I do not know what to do next. Initially i wanted to get a replacement for my Maximus X Hero motherboard, but as i have read in the forum, a lot of other people are experiencing USB problems.

    Could this be fixed with a new BIOS? New drivers? Some firmware patch for the USB chipsets? Or is it a design flaw and i would better give up and return the motherboard?

    Any advice would be apreciated. Thanks in advance!
    Miniatura de Adjuntos Miniatura de Adjuntos Strange.JPG  

    Last edited by MonkY; 03-11-2018 at 04:03 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •