Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16

Hybrid View

  1. #1
    New ROGer Array MonkY PC Specs
    MonkY PC Specs
    MotherboardAsus Maximus X Hero
    Processori7 8700K
    Memory (part number)CMK64GX4M4B3200C16
    Graphics Card #1GTX 1060 6GB
    Monitor40" Samsung 4K
    Storage #1nVM Samsung 960 Evo 500GB
    Storage #2Samsung 850 Evo 500GB
    CPU CoolerNoctua NH-D15
    CaseCooler Master Cosmos II
    Power SupplyCorsair 750W
    Keyboard Dell USB
    Mouse Logitech G502
    Mouse Pad Razer Firefly
    OS Windows 7 Ultimate 64bit
    Network RouterAsus RT-AC86U
    MonkY's Avatar
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    11

    Exclamation Asus Maximus X Hero - USB Problems all over!

    Hello everyone!

    I have just upgraded from my good old trusty Asus Maximus VIII Hero (with a 6700K CPU) to a brand new Asus Maximux X Hero (with a 8700K CPU). It was probably the best motherboard i ever had. Although i used to have a ton (over 20) of USB devices connected to my old Hero VIII, everything worked flawlessly for years!

    After the upgrade, almost nothing works when it comes to USB ports. Even my old beloved Dell Multimedia USB Keyboard... i can't even use it to enter BIOS!!! I can only use it after it boots up in Windows (it's like it doesn't get power untill a driver loads). I have tried a few keyboards, none of them were recognized at boot time, so i couldn't use DEL or F2...

    I have managed to flash the latest 1003 BIOS for Maximus X Hero, hoping there is a fix for USB issues. But nope! I have also did a CMOS reset, unplugged all other USB devices. Still wasn't able to use my keyboard or my mouse (Logitech G502) in BIOS.

    Also, even i only have one mouse and one keyboard connected, at boot time i can see something like this: "USB Controllers: 3 XHCIs / USB Devices: 2 Drives, 4 Keyboards, 3 Mice, 5 Hubs". 4 Keyboards and 3 Mice?!? What in the world? Where does that coming from? I don't even have so many keyboards and mices in my whole house...

    Also, strange things happen to my two USB external HUB's (Anker AH241 USB 3.0 Aluminum 13-Port Hub and Icybox IB-AC6702 USB 3.0 Hub). After booting up and enter Windows, i have to reset both hub's, as some of my devices do not fully work. That never happened with my old Maximus VIII Hero.

    I have tried all drivers (Intel Chipset drivers + USB 3.x drivers) from the official Asus page, and then tried the latest Intel official and un-official drivers. Also i have been using the latest ASMedia ASM2142 USB 3.1 xHCI Controller drivers.

    I do not know what to do next. Initially i wanted to get a replacement for my Maximus X Hero motherboard, but as i have read in the forum, a lot of other people are experiencing USB problems.

    Could this be fixed with a new BIOS? New drivers? Some firmware patch for the USB chipsets? Or is it a design flaw and i would better give up and return the motherboard?

    Any advice would be apreciated. Thanks in advance!
    Miniatura de Adjuntos Miniatura de Adjuntos Strange.JPG  

    Last edited by MonkY; 03-11-2018 at 04:03 PM.

  2. #2
    ROG Guru: Yellow Belt Array Deepcuts PC Specs
    Deepcuts PC Specs
    MotherboardAsus Maximus X HERO BIOS 1901
    ProcessorIntel i7 8700K @ 4.7Ghz 1.215V
    Memory (part number)CMR32GX4M4C3466C16 @ 3200Mhz 1.360V
    Graphics Card #1Asus Strix GTX 1080Ti OC 11GB
    Sound CardCreative Omni 5.1 USB
    MonitorDell 24' S2417DG
    Storage #1Samsung EVO 960 nvme 500 GB
    Storage #2Seagate NAS 8TBx2
    CPU CoolerNZXT Kraken X62
    CaseFractal Design Define R5 Black
    Power SupplyCorsair AXi760
    Keyboard Razer DeathStalker Chroma
    Mouse Razer Abyssus
    OS Windows 10
    Network RouterMikrotik

    Join Date
    Jan 2014
    Reputation
    13
    Posts
    244

    The 4-5 keyboards problem happened on my old VI HERO also all the time. Nevertheless, I did not have the problems I am having with X HERO and its USB ports.
    Just yesterday I bought a USB 3.0 hub. Of course it is not working on X HERO.
    Plugged it in my old VI HERO: works. Go figure.
    Too much money on marketing. Too few on development and testing.

  3. #3
    New ROGer Array MonkY PC Specs
    MonkY PC Specs
    MotherboardAsus Maximus X Hero
    Processori7 8700K
    Memory (part number)CMK64GX4M4B3200C16
    Graphics Card #1GTX 1060 6GB
    Monitor40" Samsung 4K
    Storage #1nVM Samsung 960 Evo 500GB
    Storage #2Samsung 850 Evo 500GB
    CPU CoolerNoctua NH-D15
    CaseCooler Master Cosmos II
    Power SupplyCorsair 750W
    Keyboard Dell USB
    Mouse Logitech G502
    Mouse Pad Razer Firefly
    OS Windows 7 Ultimate 64bit
    Network RouterAsus RT-AC86U
    MonkY's Avatar
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    11

    I have tried now using an addon PCIe USB card, hoping it will somehow bypass all the onboard Asus Maximus Hero USB chipsets and i will able to use my keyboard and mouse inside the BIOS. It's an Inateck 7 ports USB card. Unfortunately, it doesn't help.

    So, if using addon PCIe cards doesn't work, using internal ones also doesn't work... should i give up on Maximus X Hero? I never had a motherboard i couldn't get into BIOS with my keyboard. I miss the old PS/2 ones, they never failed...

    As far as i understand, the USB ports are not handled corectly by the BIOS. On the Maximus VIII Hero, the USB 2.0 chipset was enabled and used directly in BIOS, while on this Maximus X Hero, the USB 2.0 is actually used via the USB 3.0 chipset. Maybe a better USB support in BIOS could fix this...

    Anyway, i have opened a support ticket... i hope somebody will have some answers. I will post in here as soon as i get a response.

  4. #4
    Tech Marketing Manager HQ Array Raja@ASUS's Avatar
    Join Date
    Apr 2011
    Reputation
    161
    Posts
    7,454

    Monky, please list all usb devices you have plugged into the board, which ports they are plugged into, and the firmware version of each device. I may be able to ask for a replication.

    As for the number of keyboards reported by uefi, that's how the keyboard represents itself due to rollover limitations.

    Edit: As you've already contacted support, I'll let you work with them. Good luck!

  5. #5
    New ROGer Array MonkY PC Specs
    MonkY PC Specs
    MotherboardAsus Maximus X Hero
    Processori7 8700K
    Memory (part number)CMK64GX4M4B3200C16
    Graphics Card #1GTX 1060 6GB
    Monitor40" Samsung 4K
    Storage #1nVM Samsung 960 Evo 500GB
    Storage #2Samsung 850 Evo 500GB
    CPU CoolerNoctua NH-D15
    CaseCooler Master Cosmos II
    Power SupplyCorsair 750W
    Keyboard Dell USB
    Mouse Logitech G502
    Mouse Pad Razer Firefly
    OS Windows 7 Ultimate 64bit
    Network RouterAsus RT-AC86U
    MonkY's Avatar
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    11

    Hello Raja@ASUS!
    I take any help i can get... it doesn't matter if it's oficial support, user support or anyone else. So if you can help us, let us know!

    Regarding the list of all usb devices, let's ignore all of them for the moment and just focus on mouse and keyboard support, to actually be able to enter BIOS. Without that, any feature a motherboard like Maximus X Hero has is actually USELESS. How can i overclock, how can i setup my boot, how can i check settings, voltages and temps if i can't get into BIOS?

    So, the only 2 devices i can list are: Dell Multimedia USB Keyboard + Logitech G502 Proteus Core. None of them are receiving power at boot time (i can see there is no Num Lock LED on, also no lights on the mouse). They only get power after Windows is started. And that's bad...

    As i have said, i removed every USB device, except these two. I have tried all the USB ports... with no luck.

    What to do next?

  6. #6
    Tech Marketing Manager HQ Array Raja@ASUS's Avatar
    Join Date
    Apr 2011
    Reputation
    161
    Posts
    7,454

    Quote Originally Posted by MonkY View Post

    Regarding the list of all usb devices, let's ignore all of them for the moment and just focus on mouse and keyboard support, to actually be able to enter BIOS. Without that, any feature a motherboard like Maximus X Hero has is actually USELESS. How can i overclock, how can i setup my boot, how can i check settings, voltages and temps if i can't get into BIOS?

    Let's not ignore them.


    List everything plugged into the board before this issue occured. Replication on a fresh system requires retracing steps that caused the issue to manifest. Until we know more, its difficult to pinpoint why it happened. Need all info, even if you think it's irrelevant. There are a lot of things that may be involved.

    Which bios version were you using when the ports first stopped working? Was the system overclocked? Any other changes made to uefi?

    Need that info to pass to replication teams. If that cones back negative, I'll ask someone to ship a board back to hq. I'm here at hq until April 3rd, so can deal with this directly.

  7. #7
    New ROGer Array MonkY PC Specs
    MonkY PC Specs
    MotherboardAsus Maximus X Hero
    Processori7 8700K
    Memory (part number)CMK64GX4M4B3200C16
    Graphics Card #1GTX 1060 6GB
    Monitor40" Samsung 4K
    Storage #1nVM Samsung 960 Evo 500GB
    Storage #2Samsung 850 Evo 500GB
    CPU CoolerNoctua NH-D15
    CaseCooler Master Cosmos II
    Power SupplyCorsair 750W
    Keyboard Dell USB
    Mouse Logitech G502
    Mouse Pad Razer Firefly
    OS Windows 7 Ultimate 64bit
    Network RouterAsus RT-AC86U
    MonkY's Avatar
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    11

    Quote Originally Posted by Raja@ASUS View Post
    Let's not ignore them.

    List everything plugged into the board before this issue occured. Replication on a fresh system requires retracing steps that caused the issue to manifest. Until we know more, its difficult to pinpoint why it happened. Need all info, even if you think it's irrelevant. There are a lot of things that may be involved.
    Why do they matter if i just said i did a CLEAR CMOS and only connected the mouse and the keyboard via USB ports (tried all of them)? Anyway, i will try today to find a software to list all the USB devices (or maybe you want a list generated from on app - in that case, let me know what app).

    Quote Originally Posted by Raja@ASUS View Post
    Which bios version were you using when the ports first stopped working?
    I never said the ports stopped working. I said they were NEVER recognised to be able to use them in BIOS. How can i press F1 or DEL if my keyboard only shows it's ON (status LED) after booting into Windows?
    Anyway, it was the original BIOS (0802) and the update one (1003) i have used.

    Quote Originally Posted by Raja@ASUS View Post
    Was the system overclocked? Any other changes made to uefi?
    I never got to overclock or make any changes, as i repeat, i cannot enter BIOS!

    I will try some different keyboards tommorrow...

  8. #8
    ROG Member Array stainlineho PC Specs
    stainlineho PC Specs
    MotherboardMaximus X Hero WiFi-AC

    Join Date
    Mar 2018
    Reputation
    10
    Posts
    22


  9. #9
    Tech Marketing Manager HQ Array Raja@ASUS's Avatar
    Join Date
    Apr 2011
    Reputation
    161
    Posts
    7,454

    Quote Originally Posted by MonkY View Post
    Why do they matter if i just said i did a CLEAR CMOS and only connected the mouse and the keyboard via USB ports (tried all of them)? Anyway, i will try today to find a software to list all the USB devices (or maybe you want a list generated from on app - in that case, let me know what app).


    I never said the ports stopped working. I said they were NEVER recognised to be able to use them in BIOS. How can i press F1 or DEL if my keyboard only shows it's ON (status LED) after booting into Windows?
    Anyway, it was the original BIOS (0802) and the update one (1003) i have used.


    I never got to overclock or make any changes, as i repeat, i cannot enter BIOS!

    I will try some different keyboards tommorrow...
    Dang it, I got thrown off by the user who spammed two threads with a 'me too' post. Sorry about that.

    Okay...

    If your main concern is entering BIOS, try using the ASUS BOOT Setting tool from the OS; it will take you into BIOS. Then you can check if any of your keyboards work in there. If not, if you have a mouse or keyboard that does work, try disabling xHCI (save and exit), and then see what works. It's possible the devices are not fully xHCI compliant. If not that, it's simple incompatibility and you'll need to wait for a patch - and that will only happen if HQ has the same keyboards available in Taiwan.

    For the hubs, I will need the info I asked for previously. List the USB devices plugged into the board and the hubs.

  10. #10
    ROG Guru: Yellow Belt Array Deepcuts PC Specs
    Deepcuts PC Specs
    MotherboardAsus Maximus X HERO BIOS 1901
    ProcessorIntel i7 8700K @ 4.7Ghz 1.215V
    Memory (part number)CMR32GX4M4C3466C16 @ 3200Mhz 1.360V
    Graphics Card #1Asus Strix GTX 1080Ti OC 11GB
    Sound CardCreative Omni 5.1 USB
    MonitorDell 24' S2417DG
    Storage #1Samsung EVO 960 nvme 500 GB
    Storage #2Seagate NAS 8TBx2
    CPU CoolerNZXT Kraken X62
    CaseFractal Design Define R5 Black
    Power SupplyCorsair AXi760
    Keyboard Razer DeathStalker Chroma
    Mouse Razer Abyssus
    OS Windows 10
    Network RouterMikrotik

    Join Date
    Jan 2014
    Reputation
    13
    Posts
    244

    MonkY, did you enable Fast Boot by any chance?

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •