Results 1 to 4 of 4

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    1

    Question ROG GL553VD Lagging A Lot

    TLDR: Games played smoothly after Driver update then a few days later all started lagging.

    Hi there. I'm quite new to computers and the GL553VD is my first laptop given as a gift from my cousin. He doesn't live in Canada anymore so I've been having a hard time reaching someone for help.

    Before I start here are the specs of my laptop:

    • Core i7-7700HQ
    • 12 GB RAM
    • GTX 1050 Graphics Card
    • Windows 10

    I'm not exactly sure what else I could provide. Anyways when he first gave it to me, I would play Smite on the highest settings with no issues. After a few days, I've been lagging a lot, the game feels much heavier, the mouse movement isn't smooth (nothing to do with sensitivity). Then I tried playing other games such as Sims 4, which was quite laggy on the highest settings (35 FPS). I was getting low FPS on a less demanding game such as oldschool runescape on full screen which I never lagged on. Dragon Age Inquisition is pretty much unplayable.

    I see people on YouTube with the exact same computer/specs that run these games and other demanding game just fine. I saw a video where a guy ran BF1 with 50 FPS on ultra settings which is fine for me! I'm not really sure where my issue is.

    I updated to the most recent NVIDIA Driver which at first fixed all the lag issues then went back to normal after a few days. I ran virus scans as well. I'll try to answer as many questions as I can. Sorry for the lengthy post!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •