Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    1

    Question ROG GL553VD Lagging A Lot

    TLDR: Games played smoothly after Driver update then a few days later all started lagging.

    Hi there. I'm quite new to computers and the GL553VD is my first laptop given as a gift from my cousin. He doesn't live in Canada anymore so I've been having a hard time reaching someone for help.

    Before I start here are the specs of my laptop:

    • Core i7-7700HQ
    • 12 GB RAM
    • GTX 1050 Graphics Card
    • Windows 10

    I'm not exactly sure what else I could provide. Anyways when he first gave it to me, I would play Smite on the highest settings with no issues. After a few days, I've been lagging a lot, the game feels much heavier, the mouse movement isn't smooth (nothing to do with sensitivity). Then I tried playing other games such as Sims 4, which was quite laggy on the highest settings (35 FPS). I was getting low FPS on a less demanding game such as oldschool runescape on full screen which I never lagged on. Dragon Age Inquisition is pretty much unplayable.

    I see people on YouTube with the exact same computer/specs that run these games and other demanding game just fine. I saw a video where a guy ran BF1 with 50 FPS on ultra settings which is fine for me! I'm not really sure where my issue is.

    I updated to the most recent NVIDIA Driver which at first fixed all the lag issues then went back to normal after a few days. I ran virus scans as well. I'll try to answer as many questions as I can. Sorry for the lengthy post!

  2. #2
    AS185
    Guest
    Try setting the power option in Windows environment, to maximum performance. Also, turn off your antivirus for the time being when the game is played. Try testing your games on minimum graphical setting's to see how they run

  3. #3
    ROG Member Array
    Join Date
    May 2017
    Reputation
    10
    Posts
    16

    Solutions tested both on GL553VW and GL553VD/GL553VE:
    *Replace thermal paste
    *Clean your chassis and fan
    *Set power plan to "Balance"
    *NVIDIA Power Management mode must be set to "Optimal"
    *Turn up fans to Max when gaming

    Reason for doing suggested actions:
    *Replacing your thermal paste is very necessary as you are removing your heatsink to clean your fan and also your board
    *Clean your chassis and fan because it remove dust thus will result to a better thermal airflow
    *Set power plan to "Balance", as your laptop will automatically adjust it's power draw and also the exerted performance, this will make your CPU chill when idle or on undemanding areas/scenes of a game.
    *Set NVIDIA Power Management mode to "Optimal", this will allow your GPU to dynamically adjust it's power draw and exerted performance, this will make your GPU chill when idle or on undemanding areas/scenes of a game. Do not pick "Adaptive" as I've noticed some performance drops when running Overwatch in there.
    *Turn up fans to "Max" during gaming, ROG's Overboost/Auto Fan speed is a stupid feature implied into GL553 line-up, this makes your laptop run at temperatures 80 degrees Celsius all of the time during gaming. (Tested while playing Overwatch)

  4. #4
    ROG Guru: White Belt Array TimeLion724's Avatar
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    113

    Actually, you want to keep:

    1.) NVIDIA Power Management mode to "Prefer Maximum Performance"

    (If you don't you will experience a BSOD error because the GPU will go to sleep and the onboard VGA will take over and when the GPU tries awake from going to sleep it will cause a BSOD error.)

    2.) Set your power options to HiPower. (Especially if you're gaming.)

    3.) Boost fan speed RPM (to 35% from the default 30%.)
    Last edited by TimeLion724; 04-13-2019 at 06:09 PM.
    " The speed of the fallen one does not change..."

    GUIDE TO FIXING BSOD ERRORS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •