Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    6

    Exclamation I sent back my ROG rapture

    Hi there Asus guys! I hope you do not censor this post. I think it will provide you with valuable feedback, and also help other ASUS lovers from becoming ASUS haters.

    I just wanted to take the time to write this because I think you folks need to understand how upset I am. I bought a router that cost more than EUR 400. You could buy just about any high end electronic device with that kind of money; but I chose to buy a router.

    The ROG rapture was indeed an impressive beast. It had some of the best hardware you can get on a router, and it looked great too. Although the size was a bit big, I did not mind it too much since at the end of the day, I needed something powerful. So, when I bought it, I went in with high expectations.

    On the very first day, I had a lot of trouble setting it up. There was nothing wrong with the WiFi; but the VPN client is another issue. On every reboot, the VPN client forgets its credentials. Furthermore, the web interface for VPN Fusion is really buggy especially on anything other than google chrome. I contacted ASUS support in the US, spending my money to talk to those guys only for them to tell me to restart the router, and all the other boring crap that these customer service guys usually tell you. They did not help much, because the problem was with the software itself.

    I managed to sort of get the VPN working (basically there was a point in time when things started to work, and I just saved that to a restore point, and kept on uploading the file to the router to get it working again), but now I started having issues with the WiFi. For some reason, I could not longer connect to the 5Ghz-1 band; only the 5Ghz-2 band was working for me. But, hey I thought this was a problem my devices and I just didn't think much of it; if one 5Ghz band worked, I there's no real need to complain; I mostly bought it for the VPN performance.

    Two weeks later, I saw that even the 5Ghz-2 was getting flaky. I thought to myself, these things happen with routers, just a good old reboot and everything would be fine once more. Boy, was I wrong.

    Once I rebooted, the router never turned back on again. Far from the WiFi working, it just did not boot. I did the logical thing and just connected to the LAN port to see if I could get it to work. However, that did not work because I could not access
    Code:
    192.168.1.1
    . So, I just decided to do a hard reset. I downloaded the ASUS manual through a public WiFi (and I also got the firmware from there too), booted onto Windows (I have a Mac), downloaded the reset utility and then started to get to work.

    So, in order to do a hard reset, I just unplugged the power supply, held down the reset button at the back of the router with a pen, and then plugged in the power. Once I did this, the power LED started flashing slowly. I plugged into the router through an ethernet cable, and then got to work with the reset application.

    I made sure that I had an IP like
    Code:
    192.168.1.10
    and set the subnet mask to
    Code:
    255.255.255.0
    . The reset application seemed to do things perfectly well. However, after it was done and the router rebooted, the same thing happened. The router just would not turn on at all.

    This was at 3 AM in the morning. I decided to quit, and return the router back. When I went back to the shop to return it (afternoon next day), the person told me that the same thing was happening to this particular ASUS router.

    Folks, please do not buy this router. Its amazing when it does work, but unfortunately, the fact of that matter is that it does not work. No matter how good the specifications are, if your product is unstable, then you should not buy it. At the end of the day, the router is perhaps the most important piece of hardware in your house; it is the gateway to the internet, and if it keeps messing up like this, then its best not to buy this thing.

    As the replacement, I bought the ASUS RT-AC86U. Its probably the only gaming router thats stable and has good VPN performance.
    Last edited by gamesbrainiac; 03-12-2018 at 07:24 PM.

  2. #2
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Sorry to hear about the trouble you went through.

    To reset the router, instead of unplugging the power supply, you need to power off and hold down the reset button. You cannot reset the router when you have unplugged the power.

    If you are having trouble with any of the 5GHz bands, try changing the Control Channel. Use the channel which is least congested in your area.

    We will see how we can improve VPN Fusion and try to replicate your issues. Thanks for reporting it.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •