Results 1 to 10 of 77

Threaded View

  1. #23
    New ROGer Array
    Join Date
    Dec 2018

    Quote Originally Posted by MasterC@ASUS View Post
    We will investigate to see how updating the firmware could brick the Flare (COD version should not have this issue at all). I assume you downloaded the latest version of Armoury II (3.00.14) and tried to update the firmware to 0.00.35? I think it's the first time I've heard of it being bricked this way, usually the firmware reverts to the original version if not updated successfully.

    If you have tried the keyboard on multiple systems with both USB cables connected and it won't detect at all, it's faster to exchange it for a new one from your place of purchase.
    Thanks MasterC, I am arranging a replacement with the retailer. I hope you find the cause of these issues. What is different about the COD version that makes it invulnerable ?

    I don't think i'll by applying any update to my replacement, in fact if i'm updating any ASUS software i'll be unplugging the keyboard in preparation. I'd rather go without some additional features and have a reliable KB that works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts