Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    2

    ENC not working on my strix 7.1 headset

    I've had a strix 7.1 headset for several years now and its been great, but ENC is not working with this one. My first one had the same issue, I updated the firmware and it was fine after that. That headset eventually died and I RMA'd it. ENC has never worked with this headset, even after a firmware.

    Any idea what I might be doing wrong?

  2. #2
    Administrator Array MasterC@ROG's Avatar
    Join Date
    Aug 2014
    Reputation
    160
    Posts
    2,051

    How did you come to the conclusion that it is not working? It's a silly question I know, but gotta ask just in case, have you switched it on from the bottom of the audio station?

    Also, some people are under the misconception that it is the same as conventional 'Noise Cancelling'. When ENC is enabled, the mic on the audio station detects noise and filters that out so that your voice is clearer (to others) when you speak. This feature is not for reducing environmental noise in what you hear from the Strix 7.1.

  3. #3
    New ROGer Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    2

    It is switched on at the bottom.

    Essentially people are hearing me type on my keyboard, they are hearing audio from youtube videos I watch and games I play. I played with mic levels and it helped a bit but not much. This didn't seem to nearly as bad with my old headset, but this new one is not cooperating

  4. #4
    Administrator Array MasterC@ROG's Avatar
    Join Date
    Aug 2014
    Reputation
    160
    Posts
    2,051

    Try moving the audio station around to find the optimal location. Remember the mic for ENC is on the top of the audio station, it is hard to do its job properly when placed too far away from the source of the noise.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •