Results 1 to 3 of 3

Hybrid View

  1. #1
    ROG Member Array
    Join Date
    Nov 2014

    Maximus Hero X - What happened to bluetoth???

    Hi Guys,

    I have Maximus Hero X Wifi version and I am not sure what happened but bluetoth just disappeared. There is nothing in device manager or windows itself.

    I am on windows 10, checked bios and it is the latest and bluetoth is enabled.

    I tried to install the drivers from asus website but i see message: "Realtek Bluetooth is not installed on your system" and then it just exists.

    I have also one unknown device, no idea what that might be, tried to make windows update drivers, removed it, nothing worked to...

    I have no idea what is going on here....

    Is anybody else experiencing the same issue.

    Any help appreciated.

    I am not sure but maybe the latest bios broke something....

    When i run Troubleshooting for it in windows i get below message on screenshot.
    Miniatura de Adjuntos Miniatura de Adjuntos windows_message.png  




    Last edited by pit_ns; 03-18-2018 at 04:02 AM.

  2. #2
    Administrator Array Silent Scone@ROG's Avatar
    Join Date
    Mar 2016

    Have you tried going to the details tab, uninstalling driver or 'rolling back' if the option is present?

  3. #3
    ROG Member Array
    Join Date
    Nov 2014

    Yes. I tried all of that.

    However, i found on internet to disconnect the power from power supply completely.

    Which i tried yesterday, today in the morning i turned my PC back on and guess what???

    Bluetooth is present again, i am thinking after Bios was updated that might have been a required step or something.

    Anyways, seems to be fixed now.

    Hope it also helps somebody in the future


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts