Results 1 to 3 of 3

Threaded View

  1. #1
    ROG Member Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    13

    Maximus Hero X - What happened to bluetoth???

    Hi Guys,

    I have Maximus Hero X Wifi version and I am not sure what happened but bluetoth just disappeared. There is nothing in device manager or windows itself.

    I am on windows 10, checked bios and it is the latest and bluetoth is enabled.

    I tried to install the drivers from asus website but i see message: "Realtek Bluetooth is not installed on your system" and then it just exists.

    I have also one unknown device, no idea what that might be, tried to make windows update drivers, removed it, nothing worked to...

    I have no idea what is going on here....

    Is anybody else experiencing the same issue.

    Any help appreciated.

    I am not sure but maybe the latest bios broke something....

    When i run Troubleshooting for it in windows i get below message on screenshot.
    Miniatura de Adjuntos Miniatura de Adjuntos windows_message.png  

    unknown_device.png  

    windows_device_error.png  

    system_info.png  

    Last edited by pit_ns; 03-18-2018 at 04:02 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •