Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Aug 2016
    Reputation
    10
    Posts
    7

    Z170 Pro Gaming - Sound Stutter / Crackling / Popping 100% FIX

    So my dear suffering friends that own a Z170 Pro Gaming like me, i now have a solution after hours of reading and searching the internet and testing things and so on

    I just want to say that my audio crackling is gone (yes you read it right, gone!!!11), i was really pissed of because it was so disturbing to me sometimes when i want to watch a movie or want play a game silently because my child is sleeping and so on and i have tested much drivers and a few other things like linux install, the sound on linux was perfect btw, and other pci-e soundcard from a friend and so on ...

    "But before i drop the Fix, i have to say that not all credits belongs only to me, i have found the workaround by another people on this Forum but i poorly lost his nick so when you read this, dont blame me to hard ok."

    Long story Short Fix:

    Load the last driver you found for realtek HD Audio (i was aiming for a Z370 Board from asus).
    I Found Realtek_Audio_Driver_Win10-64bit_V6.0.1.8273_20180307 its from the ASUS PRIME Z370-A, just search under AUDIO from official asus site.
    After Complete install, deinstall all SONIC related Software (Sonic Radar and Sonic studio and audio related things from ASUS)
    Open Autostart in Taskmanager and set REALTEK HD-AUDIO MANAGER to DEACTIVATE.
    Restart.


    Have a nice day (and clean sound system with your great sounding onboard card

    P.S: To switch from 2.0 to 4.1 and so on you can change it in the windows audio settings, you must select your device and click on "configure".
    p.p.s: dont blame me to hard on my english, its not my native^^.
    Last edited by nec; 03-19-2018 at 09:18 PM.

  2. #2
    ROG Guru: White Belt Array
    Join Date
    Jul 2017
    Reputation
    6
    Posts
    96

    the fix is to disable fast startup. or do disable and enable graphics card in device manager.

    has nothing to do with realtek drivers. seems to be an issue on z170, z370, b250 , maximus x and v, and other models. also using a usb soundcard solves the problem.

    I still think its an asus bios or nvidia problem.

  3. #3
    New ROGer Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    1

    For me buying Dolby atmos that is in special sound in the windows column resolved the crackling and popping I hope it continues like that

    For so long without updates or fixes for this common problem is because asus do not know to solve it and for some reason the driver they make available on the motherboard website no longer fixes that issue

  4. #4
    ROG Guru: Green Belt Array MoKiChU PC Specs
    MoKiChU PC Specs
    MotherboardASUS ROG Strix Z370-F Gaming
    ProcessorIntel Core i7-8700K
    Memory (part number)Corsair Vengeance RGB DDR4 2666MHz CL16 - 16GB (2 x 8GB)
    Graphics Card #1ASUS ROG Strix GTX 1080 Ti OC
    MonitorASUS ROG Strix XG35VQ
    Storage #1SSD Samsung 970 EVO Plus 500GB
    Storage #2SSD Samsung 960 EVO 250GB | SSD Corsair MP510 240GB | SSHD Seagate 2TB
    CPU CoolerCooler Master ML240L RGB
    CaseBitFenix Enso
    Power SupplyCorsair TX850M (850W)
    Keyboard Logitech G413
    Mouse Logitech G502
    Mouse Pad PECHAM MPad-XXL
    Headset/Speakers Logitech Z333
    OS Windows 10 64 bit 21H1/VB/19043.x
    MoKiChU's Avatar
    Join Date
    Aug 2013
    Reputation
    293
    Posts
    565

    Hi,

    Try this :

    1) Audio drivers clean install : You need Realtek Audio Drivers (HDA - ASUS ROG SSx) from my HDA drivers thread. Follow scrupulously the INSTALL process (with cleanup step) of ASUS ROG SS1/SS2 motherboards category.

    2) Disable hibernation :
    - Right-click Windows Start button then click Search.
    - Search for cmd. In the search results list, right-click Command Prompt and then click Run as administrator.
    - If/When you are prompted by User Account Control, click Continue.
    - At the command prompt, type powercfg.exe /hibernate off and then press Enter then close the Command Prompt

    3) Enable MSI (Message Signaled-based Interrupts) mode on all your supported devices (see the column supported modes) with MSI Mode Utility (Right click on MSI_util_v2.exe > Run as administrator), then Apply, then close MSI Mode Utility & restart your PC.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •