Results 1 to 2 of 2
  1. #1
    ROG Member Array
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    14

    Exclamation Spatha surface issues [Resolved]

    Hi there,

    When I turned on my PC, Armoury told me that there was a firmware update for Spatha. I updated and now it's 1.69. I use my Spatha in wired mode. But after the update, the cursor is not moving at all. I changed the surface type (which was ROG Whetstone, the pad I am using) to ROG Sheath and cursor is moving just a tiny bit. I guess the new firmware has a bug with the calibration settings. Now I can't be able to use the Spatha.

    Any help? I also tried to rollback to the 1.62/1.63 beta firmware (which is the only one on the support section), it says "Spatha is not connected", but it is and Armoury sees it. I can even change the RGB LEDs.

  2. #2
    ROG Enthusiast Array Browni PC Specs
    Browni PC Specs
    MotherboardPrime X370-Pro
    ProcessorRyzen 7 1800X
    Graphics Card #1ROG-STRIX-RX580-T8G-GAMING
    Storage #1Samsung 960 M.2 NVMe 250GB
    Storage #2Samsung EVO 850 SSD 1TB
    Power SupplyCorsair RM650i
    Mouse ROG Spatha
    Headset/Speakers Logitech Z533
    Network RouterDSL-AC88U

    Join Date
    Mar 2017
    Reputation
    10
    Posts
    38

    Try selecting a different profile by holding the dpi button down and then clicking one of the buttons on the left hand side of the mouse.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •