Results 1 to 6 of 6
  1. #1
    New ROGer Array
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    13

    Bluetooth driver not working

    Hello,

    I have a problem. I have an ASUS X99 Strix Gaming Motherboard and i installed the Bluetooth driver from the Support & Driver site. But on Device Manager, it still says Bluetooth isnt detected. Bluetooth is activated on my motherboard. I can connect devices to bluetooth but the connection is so poor i loose connection after like 1meter....

    Do i need to plugin the antenna which came with the motherboard? It says its for Wi-Fi and not for bluetooh.

    Heres a screenshot:

    https://i.imgur.com/cOyEHNV.png

    Even if i try to install it through Device Manager it says there is no driver to install...

  2. #2
    ROG Guru: Grand Master Array Arne Saknussemm PC Specs
    Arne Saknussemm PC Specs
    Laptop (Model)Laptop?...No way! (Model?...Jun Amaki...yes way!)
    MotherboardROG ZENITH II EXTREME
    ProcessorTHREADRIPPER 3960X
    Memory (part number)TXBD48G4000HC18FBK
    Graphics Card #1GTX Titan X
    Graphics Card #2SLI is dead to me
    Graphics Card #3Tri SLI is even dead to Nvidia
    Graphics Card #4Quad SLI is dead to everybody especially my credit card
    Sound CardXonar Essence STX
    MonitorASUS ROG Swift PG279Q
    Storage #1Samsung 970/960/950 PRO
    Storage #22x OCZ VERTEX 3/2x WD Caviar Black 500GB / 2x WD RED 2TB/Samsung 1TBSSDs
    CPU CoolerCustom Loop: Dual D5s, Dual Alphacool Monsta 480s, XSPC Raystorm Neo TR4, EK TitanX WaterBlock
    CaseNope!...Dimastech Easy XL...let it all hang out man!
    Power SupplySeasonic 1000 Platinum
    Keyboard Corsair Strafe MK2 ROG Claymore... or Fender Rhodes Electric Piano (MKI 73)
    Mouse Corsair M65Pro or Speedy Gonzalez...not Mickey...don't do Disney!
    Headset ...firmly on neck
    Mouse Pad Mouse don't got his own pad man...lives with me
    Headset/Speakers Edifier Spinnaker...or you mean the speakers in my head...man too many voices to name them all
    OS Win XP, 7, 8, 8.1 and Windows 10 Spyware Edition
    Network Router56k modem
    Accessory #1 Umm...nice tie?
    Accessory #2 Err...belt?
    Accessory #3 3 accessories?! I'm not a girl!!
    Arne Saknussemm's Avatar
    Join Date
    Apr 2012
    Reputation
    505
    Posts
    13,666

    I would plug in the antenna and try it...I can imagine the module might use it for both WiFi and Bluetooth.

    Check your manual...I have seen sometimes a specific installation order for WiFi and Bluetooth drivers.

    Maybe disable and re-enable in windows...or disable, reboot and then re-enable in BIOS and then reboot?

  3. #3
    New ROGer Array
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    13

    Lincoln Dr Park

    Quote Originally Posted by Arne Saknussemm View Post
    I would plug in the antenna and try it...I can imagine the module might use it for both WiFi and Bluetooth.

    Check your manual...I have seen sometimes a specific installation order for WiFi and Bluetooth drivers.

    Maybe disable and re-enable in windows...or disable, reboot and then re-enable in BIOS and then reboot?
    So the antenna is basically for Wi-Fi and Bluetooth? It feels like it, i put it in and now i can go very far away with my PS4 Controller and it works great. weird, i thought its only for Wi-Fi o_O

  4. #4
    ROG Guru: Grand Master Array Arne Saknussemm PC Specs
    Arne Saknussemm PC Specs
    Laptop (Model)Laptop?...No way! (Model?...Jun Amaki...yes way!)
    MotherboardROG ZENITH II EXTREME
    ProcessorTHREADRIPPER 3960X
    Memory (part number)TXBD48G4000HC18FBK
    Graphics Card #1GTX Titan X
    Graphics Card #2SLI is dead to me
    Graphics Card #3Tri SLI is even dead to Nvidia
    Graphics Card #4Quad SLI is dead to everybody especially my credit card
    Sound CardXonar Essence STX
    MonitorASUS ROG Swift PG279Q
    Storage #1Samsung 970/960/950 PRO
    Storage #22x OCZ VERTEX 3/2x WD Caviar Black 500GB / 2x WD RED 2TB/Samsung 1TBSSDs
    CPU CoolerCustom Loop: Dual D5s, Dual Alphacool Monsta 480s, XSPC Raystorm Neo TR4, EK TitanX WaterBlock
    CaseNope!...Dimastech Easy XL...let it all hang out man!
    Power SupplySeasonic 1000 Platinum
    Keyboard Corsair Strafe MK2 ROG Claymore... or Fender Rhodes Electric Piano (MKI 73)
    Mouse Corsair M65Pro or Speedy Gonzalez...not Mickey...don't do Disney!
    Headset ...firmly on neck
    Mouse Pad Mouse don't got his own pad man...lives with me
    Headset/Speakers Edifier Spinnaker...or you mean the speakers in my head...man too many voices to name them all
    OS Win XP, 7, 8, 8.1 and Windows 10 Spyware Edition
    Network Router56k modem
    Accessory #1 Umm...nice tie?
    Accessory #2 Err...belt?
    Accessory #3 3 accessories?! I'm not a girl!!
    Arne Saknussemm's Avatar
    Join Date
    Apr 2012
    Reputation
    505
    Posts
    13,666

    It's all signals....signals need antennae...glad it's sorted

  5. #5
    New ROGer Array
    Join Date
    Dec 2017
    Reputation
    10
    Posts
    2

    I'm was having the same issue on a recent Z370-G build and thought enough to connect the antenna which appears to be both for WiFi and B/T. My bluetooth keyboard worked, but again stopped. It functions intermittently, which obviously isn't acceptable. My bluetooth keyboard is a Logitech K-810. It is rock solid on my other PC's and with the Z370, I'm only 10' feet away. After just doing a cursory search, it appears lots of folks were having similar problems with Z270 boards. Please advise if a similar problem is occurring with your M/B and especially if a fix other than the antenna one, was found.....thanks!!

  6. #6
    ROG Junior Member Array november6rr PC Specs
    november6rr PC Specs
    MotherboardAsus Rog 370-G Gaming WiFi
    ProcessorIntel 8700k
    Memory (part number)G-Skill PC3200 32GB (2X16)
    Graphics Card #1Evga 10606GB
    Sound CardOnboard and Creative
    Storage #1Samsung M.2 SSD 240GB
    CPU CoolerCustom water loop
    Power Supply750w Seasonic Gold

    Join Date
    Apr 2018
    Reputation
    10
    Posts
    1

    My bluetooth is not working as well for Strix 370-G board.
    - Fresh Win10 x64 install
    - Antenna is connected
    - Wifi and bluetooth enabled -> un-paired then paired devices again.

    = Does not work. Is there any driver or resolution for this?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •