Results 1 to 2 of 2
  1. #1
    ROG Enthusiast Array Super Gnome PC Specs
    Super Gnome PC Specs
    MotherboardROG Rampage VI Extreme Omega
    ProcessorIntel® Core™ i9-9980XE CPU @ 3.00GHz
    Memory (part number)Corsair LPX Vengeance DDR4 DRAM 2666MHz 128 GB
    Graphics Card #1Asus NVIDIA GeForce 2080 RTX Turbo (Blower type)
    Graphics Card #2Asus NVIDIA GeForce 2080 RTX Turbo (Blower type)
    MonitorJAPANNEXT JN-VT500UHD 4K 50-inch LCD
    Storage #1Crucial MX500 1 TB
    Storage #2Samsung 970 Pro 1 TB
    CPU CoolerROG Ryujin 360
    CaseThermaltake View 71 TG
    Power SupplyCORSAIR AXi Series, AX1600i 1600 watt
    Accessory #1 Noctua 140mm 3000 RPM x 4
    Accessory #2 Gigabyte GC-A 2WAY NVLINK RGB (3-slot)

    Join Date
    Mar 2019
    Reputation
    10
    Posts
    49

    EZ Update Problem

    I keep getting messages from EZ Update saying to update the chipset driver. I proceed and all seems well and the update finishes. Then just to check that it has updated because I've already done this a few times in recent days, I check for updates using AI Suite III and EZ update. It then says I need the very same driver (I think) which I just updated five minutes ago. I then update again, and repeat and it says to update again. Then again, and again and again...

    So does the system need an update and is not getting it? Or is the software just having a laugh at my expense? Or am I having de ja vu all over again or what? Help someone.

    To further add to the drama, I've also tried to update from the motherboard's support page, which worked, but still get the same thing from EZ Update--the system apparently needs an update. I've also tried to figure out what version is installed using EZ Update, but it is impossible to see the whole number and no part of it matches the number on the Support page. So there is always going to the Device Manager in Windows, but there is a long list of chipset components there, and which is which--well, hey... I'm not used to such simplicity made needlessly complex by it all.

    To make a long story short... Arg.
    Last edited by Super Gnome; Today at 09:24 AM.

  2. #2
    ROG Guru: Orange Belt Array
    Join Date
    Dec 2017
    Reputation
    12
    Posts
    294

    The EZ Update Utility is pretty much broken from day 1, as for some it finds ghost updates while for others (like me) it never found any update on any motherboard i have ever owned.
    Kinda sad when you think about it, as i wish this utility would actually make our life much easier (desktop users).

    On the lastest AI Suite III v3.00.52, there was an EZ Update Utility version update to v3.0.0.9 though for some reason it was removed from ASUS (perhaps going to be reposted later).
    I managed to install it before it has been removed but i'm doubtful it will remove any phantom updates for users experiencing it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •