Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    ROG Guru: Orange Belt Array Puffnstuff's Avatar
    Join Date
    Dec 2014
    Reputation
    21
    Posts
    446

    Maximus VII Hero Beta Bios 3503 is available

    Just saw it on the product page but haven't installed it yet.
    http://dlcdnet.asus.com/pub/ASUS/mb/...371.1515809355

  2. #2
    ROG Guru: Orange Belt Array Puffnstuff's Avatar
    Join Date
    Dec 2014
    Reputation
    21
    Posts
    446

    This fixed my spectre vulnerability.
    Click image for larger version. 

Name:	protected.jpg 
Views:	121 
Size:	54.8 KB 
ID:	73586

  3. #3
    ROG Guru: Orange Belt Array brkkab123 PC Specs
    brkkab123 PC Specs
    MotherboardAsus Maximus VIII Hero
    ProcessorIntel Core i5 6600K
    Memory (part number)G.Skill Ripjaws V DDR4 3200 32GBs
    Graphics Card #1Sapphire NITRO+ RX 480 OC 8GB
    Sound CardOnboard sound
    MonitorLG 25UM58-P
    Storage #1Samsung 850 EVO 1.0TB m.2
    Storage #2Samsung 850 EVO 1.0TB SATA & W.D. Black 2.0TB
    CPU CoolerEK Water Blocks EK-XLC Predator 240 1.1 w/push/pull add-on fans kit
    CaseNZXT Phantom 820
    Power SupplyEVGA SuperNOVA 1000 G2
    Keyboard Logitech G213 Prodigy
    Mouse Logitech G403 Prodigy
    Headset/Speakers Logitech X530 5.1
    OS Windows 10 Pro x64
    Network RouterNetgear WNDR 3700
    Accessory #1 Logitech c615 HD Webcam
    Accessory #2 Seagate Backup Desk 3.0TB
    Accessory #3 Logitech U920 Driving Force Racing Wheel/Logitech Driving Force Shifter/GT Omega Wheel Stand

    Join Date
    Feb 2013
    Reputation
    10
    Posts
    307

    That;s actually funny. On Friday night night they released UEFI version 3802, which isn't a beta.
    They just didn't list it if you selected Windows 10 as your o.s. You had to select Windows 8.1 to see it.
    It's fine on my Windows 10 pc that I just installed the Windows 10 April 2018 update on.
    Get the 3802 one, just select Windows 8.1 as your o.s. to see it listed.

  4. #4
    ROG Guru: Orange Belt Array Puffnstuff's Avatar
    Join Date
    Dec 2014
    Reputation
    21
    Posts
    446

    No sir 3503 is the highest version being shown for all OS's and its working fine on build 17134.5.
    Last edited by Puffnstuff; 04-30-2018 at 11:17 PM.

  5. #5
    ROG Enthusiast Array Sneeky PC Specs
    Sneeky PC Specs
    MotherboardHero vii
    Processorintel 4690k
    Memory (part number)16 gig avexir core red DDR3 2133
    Graphics Card #1asus strix 980
    Sound CardRog Phoebus
    MonitorROG SWIFT PG278Q
    Storage #1samsung evo 850 250gig
    Storage #2WD black 1TB
    CPU Coolercorsair h100i gtx
    Casephanteks Enthoo pro
    Power Supplycorsair HXi 750
    Keyboard cougar 700k
    Mouse cougar 700m
    Headset Qpad QH90
    Headset/Speakers Edifier S760D
    OS win10 pro x64

    Join Date
    May 2015
    Reputation
    10
    Posts
    62

    having problems when rebooting ,it sticks on Logo sgreen ? have to power off to restart

  6. #6
    ROG Guru: Orange Belt Array Puffnstuff's Avatar
    Join Date
    Dec 2014
    Reputation
    21
    Posts
    446

    Maybe you should clear your bios settings and try again. Fortunately I didn't have any issues with it.

  7. #7
    ROG Junior Member Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    3

    Cool

    Quote Originally Posted by brkkab123 View Post
    That;s actually funny. On Friday night night they released UEFI version 3802, which isn't a beta.
    They just didn't list it if you selected Windows 10 as your o.s. You had to select Windows 8.1 to see it.
    It's fine on my Windows 10 pc that I just installed the Windows 10 April 2018 update on.
    Get the 3802 one, just select Windows 8.1 as your o.s. to see it listed.
    Well, it supose you didnt check well the 3802 is found on MAXIMUSS VIII (8) not seven for us the MAXIMUSS VII (7) HERO users we aer stick to the beta. But I dont see the changes list on the beta so I'm afraid to update.

    Can someone send me the link to the updates on the BETA 3503 BIOS, or do you know maybe is there a 3802 BIOS update on the way for the HERO 7?

  8. #8
    ROG Junior Member Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    3

    Quote Originally Posted by Sneeky View Post
    having problems when rebooting ,it sticks on Logo sgreen ? have to power off to restart
    I sometimes have problems when TURNING ON the system and STICK on the LOG, then I need to HIT RESET to REBOT and the IT PASSES.

    Maybe you can TRY, TURN OFF, take the cable of power supply so the MB is totally discharge of electricity and then TRY to TURN ON THE SYSTEM AGAIN. Maybe that helps you.

    When I do and UPDATE of WIN 10 to any insider, im having to start the LOGO stick problem again, so I'll do the CABLE OFF and DISCHARTE to try to FIX.

  9. #9
    ROG Guru: Orange Belt Array Puffnstuff's Avatar
    Join Date
    Dec 2014
    Reputation
    21
    Posts
    446

    While I haven't had the post stick on the logo I have noticed that from time to time it will loiter on it for extended periods of time which I understand is caused by usb devices attached to the system.

  10. #10
    ROG Junior Member Array
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    3

    Any other review ?
    Should we expect a non beta bios or not ?

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •