Results 1 to 2 of 2

Threaded View

  1. #1
    ROG Member Array
    Join Date
    May 2018
    Reputation
    10
    Posts
    5

    Sent in my monitor for RMA, got it back with a damaged bezel and broken display.

    So two days ago I received my RMA back from the service center in California. Excited because I was able to have my monitor again, I plugged everything back in and powered it up.

    Except, when the power light indicator turned on, the display never engaged. Not even the ASUS ROG logo appeared, so I couldn't access the OSD menu or anything. I sent the monitor in with some pixel issues, and what I got back was basically a brick.

    On top of that, there is now physical damage on the bezel that wasn't there when I shipped it ,and since I never got anything saying that it arrived damaged, it must have happened during repair.

    When I called support about this issue, I was told I had to send it back yet again to have it fixed properly. However, after I hung up, I never got an RMA confirmation. Only until I once again contacted them through live chat was I able to get another RMA, so I sent it back the same day.

    So now it's been about two weeks that I haven't had a monitor which I paid $700+ for, and it now has cosmetic damage, but hopefully it will actually turn on when I get it back.

    This has been an extremely disappointing experience to say the least, and I'm going to be very hard pressed to invest in another ROG monitor ever again.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •