Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    May 2018
    Reputation
    10
    Posts
    3

    GL702ZC 2 months with Asus for repair

    One day the fans of my gaming laptop started to work on 100% all the time and I've arranged a RMA. My laptop was sent on 13.03 first the motherboard was change which I've waited for month (where is it coming from the moon ?). It didn't solve the problem then waited another part for couple of weeks which didn't solve the problem. Now I'm waiting third part which ETA is 18.05.

    How long I have to wait for my laptop to be repaired from a factory defect ? I'm suffering losses in my business and losing clients because of this laptop. If you can't repair it just send me new one. I've paid enough money for this laptop and was expecting good customer service.. I'm really pissed with Asus..
    Last edited by Yankov; 05-09-2018 at 11:22 AM.

  2. #2
    ASUS HQ Service Rep Array Bill@ASUS's Avatar
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    433

    Hello Yankov
    Can you please send me a PM with any of the following details that you do have available?

    Product S/N:
    Case ID#:
    RMA#:

    Also please pass me your contact details:
    Full name:
    Phone#:
    Email:

    I'll pass your case to related personnel and department for further investigation
    Thank you

  3. #3
    New ROGer Array
    Join Date
    May 2018
    Reputation
    10
    Posts
    3

    5 days and nobody contacted me yet.. what is going on. You call this customer service??

  4. #4
    ASUS HQ Service Rep Array Bill@ASUS's Avatar
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    433

    Hello Yankov;
    Thank you for your information. I'll pass it to our related personnel. Thank you

  5. #5
    New ROGer Array
    Join Date
    May 2018
    Reputation
    10
    Posts
    3

    I've received my laptop yesterday "repaired". As I was expecting it's not fixed properly. I've ran a game that I was able to play it before the repair on ultra and now the fps was jumping from 20 to 270 fps every second which resulted in the game running on frames. After that I tried a benchmark test on basic load the same thing everything is moving on frames. I can hear a noise, like a fan is trying to start but it's not starting , from the middle of the laptop under the screen.

    What now I need to send it again and wait 2 months ? I will advise all of my friends to not buy any asus product if I don't get a solution fast.

    I'm really pissed with you guys even if I like your products...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •