Results 1 to 4 of 4
  1. #1
    ROG Junior Member Array
    Join Date
    Jan 2017
    Reputation
    10
    Posts
    2

    GL502VS - Dies when unplugged

    Recently my Asus GL502VS dies whenever unplugged. The battery shows as charging but is always stuck at a certain amount. The battery light also flashes when the laptop is off. Without the cable the laptop will not start.

    I've tried
    1. Reinstalling battery drivers
    2. Re-flashing the Bios
    3. Removing battery and draining power / Reset CMOS battery
    4. Resetting battery plan options

    I absolutely love this laptop but hate to be having issues considering it's just slightly over a year old.
    Any ideas would be greatly appreciated!

  2. #2
    ROG Guru: Green Belt Array haihane PC Specs
    haihane PC Specs
    MotherboardCrosshair V Formula Z
    ProcessorAMD FX 8350
    Memory (part number)Gskill F3-2400C10-8GTX
    Graphics Card #1ASUS HD 6950
    Storage #1WD Velociraptor 1TB
    Storage #2Corsair Neutron GTX 120GB SSD
    CPU CoolerCooler Master Seidon 120XL
    CaseCooler Master Silencio 650
    Power SupplyCorsair HX850
    Keyboard Corsair K70 RGB
    Mouse Logitech G500
    OS Windows 7 X64
    Network RouterLinksys E2500
    haihane's Avatar
    Join Date
    Jul 2013
    Reputation
    106
    Posts
    614

    sounds like the battery is no longer able to hold charge.

    any ASUS service center you can drive to for them to look at it?
    no siggy, saw stuff that made me sad.

  3. #3
    ROG Junior Member Array
    Join Date
    Jan 2017
    Reputation
    10
    Posts
    2

    Quote Originally Posted by haihane View Post
    sounds like the battery is no longer able to hold charge.

    any ASUS service center you can drive to for them to look at it?

    The wired thing is the battery issues are sudden. They the day before the battery was 100% fine.

    There is a service center somewhat nearby. Driving wouldn't bee too bad although I'd prefer to go only if I absolutely have to.

  4. #4
    New ROGer Array
    Join Date
    May 2018
    Reputation
    10
    Posts
    3

    I have same issue, could it be because its installed "microsofts basic battery/charging drivers" i didnt take much notice if there was any rog specific ones that came with my laptop, but yeah my pc is in a perpetual battery saver

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •