Results 1 to 2 of 2
  1. #1
    ROG Junior Member Array
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    1

    G751JY battery Need Help!

    Hi guys, my G751 sometime showing "charging and "Not charging". the battery LED indicator is flashing green and orange at times. e.g orange for 60sec, then flash 3 sec green). today, it even auto shut down for a few time even when its plugged in to the power socket.

    Things i have tried:
    - uninstall/ reinstall battery API
    - hold power button for 10sc when se ROG screen when start up
    - hole power button for 1min when the laptop is shutdown and power supply unplgged

    All doesnt work

    Please help and advise if changing battery will solve this issue? or its software issues?

    Thank you in advance!

  2. #2
    ROG Enthusiast Array mpgioia's Avatar
    Join Date
    Sep 2015
    Reputation
    10
    Posts
    30

    The battery chipset and/or chemistry in either the G75#'s or just the G751 is horrible.
    I've bought two since my original purchase 4 years ago.
    They last about 1 year before doing all that you have mentioned above.
    Separately, the latest Win10 update (10.0.17134) has seen a software bug where the battery task tray icon report 5% capacity when plugged into mains, yet when you remove the plugpack receptacle the battery emoticon flashes with correct charge.. aka 100% (mind you.. diminishes mighty fast).

    That's my 2cents with my G751JY.. interested on others to chime in. But searching this forum subject.. you can see a ton of posts on battery issues and horrible performance.. so I don't think it's just me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •