Page 4 of 4 FirstFirst ... 2 3 4
Results 31 to 32 of 32
  1. #31
    ROG Member Array
    Join Date
    Jun 2018

    I tried the Mac version of the ASUS router rescue software. I tried several version of firmware and they all stall out at 80%. Resetting the router brings it back up with the current version of firmware. I saved my settings and was able to upload them, at least.

    Hey ASUS, how about telling us more about the latest firmware or give some detailed instructions for downgrading. I bought this router specifically for VPN Fusion which now doesn't work at all.

  2. #32
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014

    To see the release notes for the latest firmware or to report any issues, please go to this thread:

    To try reverting to an older firmware (click on See all downloads to reveal more):

Page 4 of 4 FirstFirst ... 2 3 4

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts