Results 1 to 2 of 2
  1. #1
    ROG Junior Member Array
    Join Date
    Mar 2016
    Reputation
    10
    Posts
    1

    Windows 10 Laptop Doesn't Recognize Mouse or Keyboard, Data Retrieval

    Brief problem overview:

    When turning on my laptop, I get to the Windows lock screen, but my laptop's keyboard does absolutely nothing and neither does my mouse or touchpad. The only thing I can do here is shut the laptop off by holding the power button. Since I can't get into Windows and I have no idea what's wrong, I want to recover the data on the drives somehow. Unfortunately, safe mode didn't work, and when booting from Linux on a USB drive, two of the three drives in this laptop are not recognized (both of which are NVME drives), and I need to retrieve some data from those drives. The SATA HDD is recognized by Linux, but in read-only mode. I don't know what to do to get the data on the two NVME drives.

    The details (there's a bit of a story to this, so hold on tight):

    Last night, I was using Windows 10 Home Build 17134 on my personal ASUS ROG G752VY laptop. I plugged in one of my NCredible PNY 32GB flash drives (that was most likely corrupted in some way because it had write protection unintentionally enabled on it) and I plugged in another one of my functional flash drives (a Verbatim 32 GB drive) to try and move files over from the PNY to the Verbatim flash drive. Only one problem; for some reason, Windows only recognized the PNY drive, and not the Verbatim no matter how many times I plugged it in (I unplugged and replugged the Verbatim drive probably somewhere around 6 to 10 times, including in different USB ports on the laptop), even though one of my older laptops recognized the Verbatim drive with no problems.

    So I thought, why not try the solution to everything; let's restart the computer, right?

    Big mistake. If only I had known what was to come.

    With both the PNY and the Verbatim flash drives still plugged into the USB ports on the computer, I restarted Windows 10. When the lock screen appeared, pressing keys on the keyboard did absolutely nothing (normally pressing a key opens the lock screen and brings you to the field where you enter your password), and no mouse that I plugged in, wired, wireless, or even the touchpad, would move the cursor (the cursor didn't even appear on the lock screen). Plugging in a wired external USB keyboard also did nothing. So the only thing I could do was press and hold the power button to shut it off.

    After waiting a few minutes, I pressed the power button again, turning the laptop back on. Windows booted up, taking me to the lock screen... and still nothing worked. The keyboard does nothing, and neither does any mouse or the touchpad. Desperate, I decided to turn it off and try again.

    This time, when the manufacturer logo appears before booting into Windows, I see the text "Please wait..." at the bottom, and it takes me to Windows advanced recovery options. And guess what! When I'm in here, the mouse and keyboard both work! So this indicates that it's an issue with my specific Windows installation, not with the hardware. So once I'm in here, I try several different options:

    First, I try booting into safe mode. This time, instead of showing me the typical lockscreen with the time, it immediately shows me the field where I enter my password. Unfortunately, even in safe mode, the mouse, keyboard, touchpad, and even external keyboard all still do absolutely nothing.

    Then I tried "startup repair," but it reported that it couldn't do anything, so that didn't help much.

    At this point, it was 3 AM, so I was too tired to continue; I gave up, unplugged the laptop, went to bed hoping that it would be magically fixed in the morning.

    Well, it wasn't; all the same issues persisted this morning, so I decided that the best thing for me to do would be to at least get the files off the drive that I needed quickly. So I put xUbuntu on an external SanDisk Ultra flash drive (using a different laptop to do this), booted into the BIOS on the ASUS ROG laptop (the laptop's keyboard works in the BIOS), and changed the boot priority to the flash drive.

    I didn't fully install xUbuntu; I just ran the "try Linux" option you get whenever you boot from a drive you wrote an xUbuntu ISO to. So now I'm inside xUbuntu (running on the SanDisk flash drive), and my keyboard and mouse are working perfectly. I can navigate around, so I go to check the disks; but guess what; GParted and xUbuntu only see the 1TB HDD inside the laptop, and I can't access the other two drives; it doesn't see the 256GB NVME SM951 drive that Windows is installed in, nor does it see the other, separate 256GB SM951 that I have some important files on (these SM951s were never running in RAID, Windows always treated them as two separate drives). Great. In addition, for some reason, the HDD drive that it does see will let me copy files from the drive, but it won't let me delete any files from it (every file and folder has a lock icon next to it).

    Researching this problem, apparently I need to change the SATA Mode Selection in my BIOS to "ACHI," but of course my BIOS only shows "RAID" for some reason (there's nothing else to select). So that solution apparently won't work. At this point, I honestly don't know what to do.

    Whenever I'm in the advanced startup options, I do see the choice to "remove everything and reinstall Windows," which theoretically should fix the problem based on my observations. However, I do have important files on the C: Drive that I would like to manually back up before trusting that this option won't remove them. Theoretically, everything on the other NVME SSD would be unaffected. I just want to save this as the last resort, though, and only use it after I've got all the data on these drives backed up.

    I could take apart the computer and remove the drives, but don't have the hardware necessary to retrieve data from the NVMe drives outside of that laptop. I also really don't want to spend any money.

    So, it's been a relatively fruitless adventure so far, and I honestly don't know what to do. Does anybody have any idea what actually happened here or what I need to do in order to get the data off the two NVMe drives? Any help is greatly appreciated. Thank you.

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    294
    Posts
    7,403

    How long did you wait at the lock screen? Sometimes Windows will take several minutes to install device drivers for input devices. So let it sit at the login screen for 5 minutes or until the activity light stops. Alternatively Windows could be freezing up and it might not have anything to do with the keyboard & mouse.

    You may be able to access the drives with a portable windows USB stick. Not one that you install from, but where Windows is actually running on the USB. I've used this tool to do that before:
    https://www.easyuefi.com/wintousb/
    Note that it will be *extremely* slow to boot and load into Windows because USB flash drives were not designed for this.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •