Results 1 to 1 of 1
  1. #1
    New ROGer Array MHack PC Specs
    MHack PC Specs
    Laptop (Model)Asus Zenbook UX333 + Macbook Pro
    MotherboardZ390-F + Z370 Plus
    Processori5-9400 + i5-8400
    Memory (part number)8, 16, 16, 16

    Join Date
    Jun 2018

    TUF Z370-PLUS - Latest BIOS Wierdness

    Tried to install the latest BIOS 0805 for my Z370-PLUS [ it's already 0805 but since dates differ between Asus site and the Bios, tried anyway ].

    And it tells me ":-) You have aready the latest BIOS".
    Fine, normal, after all.
    Doing Exit...

    Then for some reasons the Boot Order was changed!
    The "Network Stack" has been enabled and could not boot anymore [ "Checking Media presence..." ]
    To flash a new BIOS, the net stack is enabled automatically it seems then, in case the BIOS is already the latest, the flash utility doesn't restore the settings - it seems.

    So had to fix the boot order.

    Please fix your BIOS bugs... [ and still waiting for the WoL bug to be fixed ]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts