Results 1 to 3 of 3
  1. #1
    ROG Junior Member Array
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    2

    Asus Sabertooth Z77

    I built a pc using an Asus Sabertooth Z77 and Intel i7 processor two years ago, and now I've had a problem that I've narrowed down, through elimination, swapping RAM, HDD, audio card, network card and power supply, to be either the motherboard or the processor. I've read that a bad VR on the motherboard can take out a processor, so even though I've got a new i5 processor and a new 1155 slot motherboard (P8H67), I'm afraid to proceed, not wanting to damage either.

    Of course I'd rather use the Sabertooth MB with the new processor, but I'm afraid of damaging the processor if the problem turned out to be the MB.

    I could just put the new processor onto the P8H67, but then I'll never know if my i7 processor is good, or if both the i7 and motherboard were damaged together.
    The PC worked one evening when I shut the PC down, and the next morning, it would not start. The fans would all spin for a second and then just shut down.

    Any advice on how to proceed would be appreciated.

    All other internal components of the defective system have been placed into another cabinet, and are working on yet another P8H67 board I've had for 10 years without any problems.

  2. #2
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    99
    Posts
    4,104

    Have you replaced the BIOS battery on you MB?
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  3. #3
    ROG Junior Member Array
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    2

    Yes, I did, but it was from a package that was a few years old. I suppose it's worth buying a new battery to be certain.
    Thanks! I'll post back over the next week to confirm if it solves the problem or not.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •