Results 1 to 2 of 2

Threaded View

  1. #1
    ROG Member Array Gam3rNa5h PC Specs
    Gam3rNa5h PC Specs
    Laptop (Model)ROG STRIX GL502VS-WS71
    MotherboardIntel® Mobile HM175 Express Chipset
    ProcessorIntel® Core™ i7 7700HQ 2.8 GHz
    Memory (part number)16GB DDR4 2400MHz
    Graphics Card #1NVIDIA GeForce GTX 1070 8GB GDDR5
    Monitor15.6" FHD 60Hz IPS (16:9) Anti-Glare Matte Type Screen w/ G-Sync (1920x1080)
    Storage #1256GB M.2 PCIe SSD
    Storage #21TB 5400RPM SATA HDD
    CPU CoolerCopper CPU Heatsink
    Power Supply230W AC Adapter; Output: 19.5V DC, 9.23A, 180W, 4 Cells 62 Whrs Battery
    Keyboard Illuminated Chiclet Keyboard
    Mouse Pad ASUS Precision Touchpad
    OS Windows 10 Home (64-bit)

    Join Date
    Nov 2017

    GL502VS Battery not detected

    I've got a gl502vs and its saying the battery is not detected. Happened once about a week back but was solved after restarting. Today it occurred again. The laptop is not booting without ac power connected, but it does not turn off if I disconnect ac power while the laptop is on, indicating the battery is working. Guessing its a software issue. Uninstalled the two drivers i saw under Battery in device manager, then reinstalled by clicking "scan for new hardware", but it didn't solve the problem. Battery is inside the case and so not detachable. How do I fix this? Ask if you need more info. This is all i could think of at the moment. Thanks.

    UPDATE: Fixed it. Removed the case and detached the battery. Then booted on AC power, went to device manager and uninstalled driver under battery. Then shutdown, inserted battery and booted up. The system recognised the battery and now its working fine. I think it might have been a windows update that messed up the drivers. Found the solution in
    Last edited by Gam3rNa5h; 07-07-2018 at 12:28 PM. Reason: SOLVED

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts