Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    7

    Question Asus ROG GL702VS not working after Windows 10 1803 update

    So...After a system update, the keyboard has stopped working for the second time in less than a year. I ahve contacted Asus support but I'm out of warranty. Either Asus is not providing the correct drivers for this keyboard, or Microsoft is pushing bad drivers... I have tried:

    Factory reset, tried using third party tools to find missing drivers, uninstalling and then installing ATK, search for local drivers, and nothing has fixed this issue. At first i though of a bad driver configuration, but it didn't strike me an update could potentially messed up the keyboard settings to the point of total destruction. I booted into a live Ubuntu USB and the keyboard works perfectly fine. I'm thinking of finding someone with Win 10 1709 or earlier to get a copy of their keyboard drivers and try to use these on my Win 10 1803. Any recommendations ?

  2. #2
    ROG Guru: Yellow Belt Array
    Join Date
    Jun 2017
    Reputation
    10
    Posts
    204

    Something weird is going on with your windows install.

    You have to do a format / fresh install of windows.

    I don’t think it’s a driver issue, sound more like a corrupt file.. or else there would be tons of people affected by this issue..*

  3. #3
    ROG Member Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    7

    yeah, the Windows updated messed up the drivers. I was able to fix it by going into device manager, right click the device, then update driver,. then browse my computer, then let me pick from a list, and picked the HID -compliant device. This made the keyboard work again.

  4. #4
    New ROGer Array
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    1

    What did u do exactly?

    Quote Originally Posted by jalhpepe View Post
    yeah, the Windows update messed up the drivers. I was able to fix it by going into device manager, right click the device, then update driver,. then browse my computer, then let me pick from a list, and picked the HID -compliant device. This made the keyboard work again.
    HI, can u please tell me what have u done exactly? cuz I'm facing the same problem!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •