Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    4

    Exclamation Crosshair VII Hero WiFi Stopped Working

    Hi all, today I'm having a really annoying problem, my wifi adaptor doesn't want to work, windows says that can't start it and there's a problem with it.
    I already reinstalled win10, drivers and updated the bios, but still nothing, the wifi doesn't work.
    Do you guys have any suggetions on hwo to fix it?

  2. #2
    ROG Guru: Blue Belt Array gupsterg PC Specs
    gupsterg PC Specs
    MotherboardAsus Maximus VII Ranger
    Processori5 4690K
    Memory (part number)HyperX Savage 2400MHz 16GB
    Graphics Card #1Sapphire R9 Fury X (1145/545 Custom ROM)
    MonitorAsus MG279Q
    Storage #1Samsung 840 Evo 250GB
    Storage #2HGST 2TB
    CPU CoolerThermalRight Archon SB-E X2
    CaseSilverstone Temjin 06
    Power SupplyCooler Master V850
    Headset/Speakers HyperX Cloud
    OS Win 7 Pro x64 / Win 10 Pro x64
    gupsterg's Avatar
    Join Date
    Feb 2015
    Reputation
    102
    Posts
    982

    Linux can be run from a USB stick. Use something like Rufus to place an ISO of Linux Mint v19 (Cinnamon) on USB. See if WiFi works, you don't need to even install Linux, it will run as a "live" version off install USB. This way you'll know if MS OS is issue. As you've already reinstall W10 perhaps module is faulty.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •