Results 1 to 3 of 3
  1. #1
    ROG Junior Member Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    3

    sonic studio 3 with SPIF connector - no equalizer - no settings to customize sounds

    please help me!

    recently i bought a asus strix z370-g motherboard which costs more than 180€
    it has a supremefx s1220 realtek chip onboard.
    i installed the asus sonic III application because i need an equalizer for my soundsettings
    i want to boost my bass when i use the headset etc.
    it was hard for me to find out that asus disabled all soundsettings in the sonic III
    when using the spif connector. errormessage: "Sonic Studio does not support the current default audio device"
    after that really bad experience i tried the realtek driver form the microsoft catalog
    because i wanted back the realtek hd audio manager - this application i used also on my old asus motherboard
    it has a buildin equalizer - this is all i need.
    after installation the realtek icon was in the taskbar - but when i click on it, it seems that a branded
    version of hd audio mangager opens - without equalizer i can only change some connection settings.

    if nothing fix this problem i have to buy a pci-e soundcard because i need this equalizer.
    i have also tried some equalizer application from the internet - all are bad! f.e. apo equalizer

    i want to have the full version of the realtek hd audio manager with the equalizer - is that possible???
    registry hack? or delete some branded settings file?
    one picture shows what i get (branded) and the other picture shows what i would like to have...
    Miniatura de Adjuntos Miniatura de Adjuntos hdbrand.png  

    hdfull.PNG  


  2. #2
    ROG Guru: Yellow Belt Array SaLSouL PC Specs
    SaLSouL PC Specs
    MotherboardCrosshair VI Extreme
    ProcessorRyzen 7 2700x
    Memory (part number)trident RGB CL16 3200mhz 32GB
    Graphics Card #1MSI Gaming 6GB GTX 980Ti
    Graphics Card #2MSI Gaming 6GB GTX 980Ti
    Sound CardAstro A50 Wireless
    MonitorPhillips BDM4037U 40" 4k UHD Monitor
    Storage #1samsung 850 pro raid 0
    Storage #2WD Black 1tb Raid 0
    CPU CoolerCorsair H115i
    CaseCoolermaster Cosmos 2
    Power SupplyCorsair ax 1200i
    Keyboard Corsair K95 Platinum
    Mouse Corsair Scimitar RGB Pro
    Headset Astro A50 Gaming Wireless
    Mouse Pad corsair massive
    OS Win 10 x64 pro
    Network RouterAsus AC-3200
    SaLSouL's Avatar
    Join Date
    Mar 2012
    Reputation
    13
    Posts
    228

    There is one version that works for me but it is the inital release of SS3 for my board that it works on and only this version, it has susequently been blocked or removed in later versions onwards.

    this one works with SPDIF & my astro a50s

    If I update the suite it stops working.

    here is the link the version that works is Version 6.0.1.7997

    http://dlcdnet.asus.com/pub/ASUS/mis...633.1533899926

  3. #3
    ROG Junior Member Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    3

    Quote Originally Posted by SaLSouL View Post
    There is one version that works for me but it is the inital release of SS3 for my board that it works on and only this version, it has susequently been blocked or removed in later versions onwards.

    this one works with SPDIF & my astro a50s

    If I update the suite it stops working.

    here is the link the version that works is Version 6.0.1.7997

    http://dlcdnet.asus.com/pub/ASUS/mis...633.1533899926
    thanks for your answer!
    i have tried the generic realtek driver and it worked for me!
    http://www.mediafire.com/file/esmmqs..._Win7_WHQL.zip

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •