Results 1 to 10 of 11

Hybrid View

  1. #1
    ROG Member Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    6

    Exclamation Asus ROG Strix GL503VD sound enhancement problem

    Some games make my laptop speaker create a buzzing sound and the game lags every time it buzzed. Then suddenly the volume becomes very low that I can barely hear anything. After that, I noticed that Sonic Radar no longer works too, and when I opened sound panel I got an error "Windows has detected that audio enhancements for the following device are causing problems: Realtek HD Audio", "Do you want to reenable it again?". I pressed yes, but it doesn't fix the sound or anything, it just creates a very low quality sound for music and creates no sounds for any games that I had to turned the volume up to 100 to hear it.

    Without that enhancement, I can barely hear anything and the sound quality becomes very bad, and no longer surround sound. I had to reset my laptop and start from fresh every time this problem occurs, because it's the only fix I know but I can't do that forever.

    - I have everything up to date.
    - reinstalling through device manager fixed nothing, or make it worse.
    - Changing my realtek into 'High Definition Audio Device' fixed nothing.
    - Most importantly, my Realtek has no enhancement setting so where the hell can I reenable it?

    Here is my spec:
    Asus ROG Strix GL503VD (that has dual speakers in it)
    Intel Core I7-7700HQ
    GeForce GTX 1050
    Speakers (Realtek High Definition Audio)

    Sorry for my bad english, Any help would be very appreciated as this problem drives me insane.

  2. #2
    ROG Member Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    6

    Maybe I was unclear, let me make it short:

    1. When I opened some games, the sound lagged as it created buzzing sound followed by graphic lag. Then the enhancement got disabled (I don't know what enhancement it has, because I can't find any enhancement tab in Realtek)
    2. After that incident, Sonic Radar and Sonic studio no longer worked. Sonic Radar no longer gives direction, Sonic Studio no longer apply the settings.
    3. Sound becomes inaudible and low quality. I can hear music and windows system sound normally, but I can't hear any sound almost in every video games. The sound got distorted too if I set my volume up to 60. It was clean and loud before it happened.

    My specific laptop is Asus ROG Strix GL503VD SCAR Edition. and Realtek HD Audio. The only solution is to reinstalling windows, which I don't want to because it happened so often.
    Sorry for posting in wrong section, and my bad english.
    Last edited by Kompaktive; 08-10-2018 at 12:06 AM.

  3. #3
    New ROGer Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    1

    Angry I have the problem with the same details pls help,I worked on all the solutions

    Quote Originally Posted by Kompaktive View Post
    Maybe I was unclear, let me make it short:

    1. When I opened some games, the sound lagged as it created buzzing sound followed by graphic lag. Then the enhancement got disabled (I don't know what enhancement it has, because I can't find any enhancement tab in Realtek)
    2. After that incident, Sonic Radar and Sonic studio no longer worked. Sonic Radar no longer gives direction, Sonic Studio no longer apply the settings.
    3. Sound becomes inaudible and low quality. I can hear music and windows system sound normally, but I can't hear any sound almost in every video games. The sound got distorted too if I set my volume up to 60. It was clean and loud before it happened.

    My specific laptop is Asus ROG Strix GL503VD SCAR Edition. and Realtek HD Audio. The only solution is to reinstalling windows, which I don't want to because it happened so often.
    Sorry for posting in wrong section, and my bad english.
    help

  4. #4
    ROG Guru: White Belt Array
    Join Date
    Jul 2018
    Reputation
    11
    Posts
    120

    Maybe you should contact ASUS via live-chat on their site and ask them directly?

    It seems that nobody have the same issue like yours.

  5. #5
    ROG Member Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    6

    Quote Originally Posted by McCoy View Post
    Maybe you should contact ASUS via live-chat on their site and ask them directly?

    It seems that nobody have the same issue like yours.
    Unfortunately asus live chat only available in US and Canada. I have no time to go to ASUS Center because it always had a long queue and I believe it only repairs hardware related, as there is no problem with my hardware.

    Quote Originally Posted by hmnnmh View Post
    help
    For a workaround, I completely disable Sonic Studio and prevent it from startup again. Now I can hear in-game sound normally, with expense of bad quality sound and non-surround.

    Still, I need a solution to fix because I've paid a lot for this laptop, so it's better be damn working as advertised!
    Last edited by Kompaktive; 08-29-2018 at 11:36 PM.

  6. #6
    New ROGer Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    3

    This is probably too late but... Have you tried disabled Sonic Studio from startup? I did that and now I have sound in most of the games and programs. Use Sonic Studio only give me problems.

  7. #7
    ROG Member Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    15

    I have Gl503VM and have the extact same issues.

    https://rog.asus.com/forum/showthrea...h-Asus-Gl503VM
    Last edited by Jason Brody; 02-08-2019 at 03:30 PM.

  8. #8
    New ROGer Array
    Join Date
    Jun 2019
    Reputation
    10
    Posts
    1

    Exclamation Sonic Studio 3 Stopped working for me also after playing Overwatch

    At first, I thought it was my CPU and GPU overheating due to the game making wired sounds and lagging so I fixed that I even installed software to monitor the temperature of both the CPU and GPU during gameplay and notice that the temperature was at 56C to 70C which is normal. So after doing some research, I came across this thread and it describes everything that I have been having issues with. But let me point something out so the sound quilty was bad before but didn't know that it was Asus sonic studio 3 that was causing the problem until a few days ago I decided to use the software for the first time and for some miracle it was working but there were a few times that the speakers lost the sound of the game and started to make weird sounds, while playing Overwatch it kept doing it off and on until it did it for the last time and I was never able to control the sound quilty through sonic studio 3. however it works when I plug in headset into computer but there was this one time when I unplug it during a match in Overwatch and it closed the game weird I just wanted to point that out if that helps to further find a solution.

    I have tried updating the software Sonic Studio 3 ver 3.6.12.44181 to Sonic Studio 3 ver. 3.6.42.51937 I even updated the Sonic Radar 3 to ver 3.6.42.51937 but nothing I am still with the same issue having low sounds for Overwatch
    I ended Uninstalling and reinstalling the original version that came with my laptop but nothing and now Sonic Radar 3 lunches and crushes every time I try opening it.

    So if it is not CPU or GPU overheating and if updating it doesn't fix the problem than I don't know what is causing it.
    I did somewhere that Windows 10 can the problem be conflicting with Sonic Studio 3 since they both try to direct sounds but I don't I am just putting what I have been reading.

    One more thing and no this person that made this thread isn't the only one with the issue it's just that we sometimes we dont think that software like Sonic Studio 3 could be causing the problem so we blame the game or the CPU or GPU for the problems we are facing.

    My Specs for Laptop are Asus Rog Strix GL503VD With BIOS 310 Intel Core i7 7700HQ Nvidia GeForce GTX 1050

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •