Results 1 to 10 of 11

Threaded View

  1. #1
    ROG Member Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    6

    Exclamation Asus ROG Strix GL503VD sound enhancement problem

    Some games make my laptop speaker create a buzzing sound and the game lags every time it buzzed. Then suddenly the volume becomes very low that I can barely hear anything. After that, I noticed that Sonic Radar no longer works too, and when I opened sound panel I got an error "Windows has detected that audio enhancements for the following device are causing problems: Realtek HD Audio", "Do you want to reenable it again?". I pressed yes, but it doesn't fix the sound or anything, it just creates a very low quality sound for music and creates no sounds for any games that I had to turned the volume up to 100 to hear it.

    Without that enhancement, I can barely hear anything and the sound quality becomes very bad, and no longer surround sound. I had to reset my laptop and start from fresh every time this problem occurs, because it's the only fix I know but I can't do that forever.

    - I have everything up to date.
    - reinstalling through device manager fixed nothing, or make it worse.
    - Changing my realtek into 'High Definition Audio Device' fixed nothing.
    - Most importantly, my Realtek has no enhancement setting so where the hell can I reenable it?

    Here is my spec:
    Asus ROG Strix GL503VD (that has dual speakers in it)
    Intel Core I7-7700HQ
    GeForce GTX 1050
    Speakers (Realtek High Definition Audio)

    Sorry for my bad english, Any help would be very appreciated as this problem drives me insane.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •