Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    ROG Member Array
    Join Date
    Aug 2018
    Reputation
    11
    Posts
    16

    M.2-1 Configuration in BIOS

    I have the Maximus X Hero MB and a 970 EVO 500gb drive in the M.2 slot but when I look in the BIOS to see if there are any settings, I only see 2 places for any possible changes and I'm not at all familiar with them.
    One is listed as the M.2-1 Configuration with choices for Auto-SATA-PCIe (and is set to Auto)
    The other is M.2-2 PCIe Bandwidth Control and is set to X2 but there is an option to set to X4.

    So, what should these be set too?

    Thanks in advance for your help.

  2. #2
    ROG Guru: Orange Belt Array chevell65 PC Specs
    chevell65 PC Specs
    MotherboardROG Strix Z370-H, ROG Maximus VII Z97
    ProcessorIntel 4790K 4.6GHz, Intel i5 8400, Intel e8600 Wolfdale, Intel Q9650 Yorkfield, Intel E6750 Conroe
    Memory (part number)16GB G.Skill PC3600
    Graphics Card #1GTX 660 OC
    MonitorAsus 23"
    CaseCorsair clear case
    Power SupplyThermaltake
    Keyboard Logitech G15
    Mouse Logitech G9
    OS Windows 10 Pro
    Network RouterDLink DIR-655, Asus AC88
    chevell65's Avatar
    Join Date
    Oct 2014
    Reputation
    56
    Posts
    367

    You want to use PCIe and X4 when possible.

    More than one GPU gets you X2 mode.

  3. #3
    ROG Member Array
    Join Date
    Aug 2018
    Reputation
    11
    Posts
    16

    Thanks. And making that change won't affect the current info on the EVO drive, meaning, I won't lose anything on it?

    I just realized too I never even went to Samsung's site and download the driver though I'm not sure that will change anything.
    Last edited by Beerlord; 08-21-2018 at 03:56 PM.

  4. #4
    ROG Enthusiast Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    51

    I have a 970 PRO 1Tb Samsung NVMe drive in the main M.2 slot on my Hero X. Regardless of whether I set the M.2-2 PCIe Bandwidth Control to x2 or x4, every time I reboot and enter the BIOS it has always reverted to x2. This is the case whether I have the first M2-1 option set to Auto or PCIe. It *always* reverts to x2 when I go into bios. Anyone else not have it revert to x2?

  5. #5
    ROG Member Array
    Join Date
    Aug 2018
    Reputation
    11
    Posts
    16

    I've left mine to Auto for now but have not tried changing X2 to X4. Do you have yours set to PCIe or Auto.

    Doing some net research, the opinions are many. Some say to leave it to auto and try X4 and others say Auto is the same as PCIe and set that to X4.

  6. #6
    ROG Guru: Brown Belt Array NemesisChild PC Specs
    NemesisChild PC Specs
    MotherboardASUS Maximus X Hero (WI-FI AC)
    ProcessorIntel i7 8700K
    Memory (part number)G.Skill F4-3600C16D-16GTZR
    Graphics Card #1Nvidia GTX 1070 Ti FE
    Graphics Card #2Nvidia GTX 1070 Ti FE
    MonitorASUS ROG Swift PG278Q
    Storage #1Samsung 970 PRO 512GB NVMe M.2
    Storage #2WD Black 2TB 7200 RPM 64MB Cache
    CPU CoolerNZXT Kraken X42
    CaseCooler Master HAF 932 Advanced
    Power SupplyEVGA SuperNova 1200 P2
    Keyboard Logitech G910 Orion Spark
    Mouse Logitech G703 Wireless
    Headset Logitech G Pro
    Mouse Pad SteelSeries
    OS Windows 10 Home x64 (UEFI)
    Network RouterLinksys WRT1900AC
    NemesisChild's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    1,788

    Quote Originally Posted by Beerlord View Post
    I've left mine to Auto for now but have not tried changing X2 to X4. Do you have yours set to PCIe or Auto.

    Doing some net research, the opinions are many. Some say to leave it to auto and try X4 and others say Auto is the same as PCIe and set that to X4.
    Set it PCIe, it should automatically default to X4. You can verify the interface through Samsung Magician software.

    Yes, install the Samsung NVME driver, it's faster than the generic MS driver.
    Intel i7 8700K@ 5.2GHz (Delidded)
    ASUS Maximus X Hero (Bios 1801)
    NZXT Kraken X42
    G.Skill TridentZ@ 4000MHz CL16 2x8GB
    SLI: 2x Nvidia GTX 1070 Ti FE@ 2025/2025MHz
    OS: Samsung 970 PRO 512GB NVMe M.2
    Storage: Samsung 960 EVO 500GB NVMe M.2
    Storage: 2x Samsung 850 EVO 500GB
    Storage: WD Black 7200 RPM 64MB Cache 2TB
    EVGA SuperNova 1200 P2
    Cooler Master HAF 932 Advanced

  7. #7
    ROG Member Array
    Join Date
    Aug 2018
    Reputation
    11
    Posts
    16

    Thanks much!

  8. #8
    ROG Enthusiast Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    51

    Mine stays at x2 even if I manually change the setting to X4 - if I go back into the BIOS after a reboot it is back to X2 every time. This happens whether I set the first option to Auto or PCIe. What could this possibly be the result of...?!


    That said, if I run Samsung Magician, it says the Interface is "PCIe Gen. 3 x 4".

  9. #9
    ROG Enthusiast Array kens30 PC Specs
    kens30 PC Specs
    MotherboardAsus ROG Maximus X Code
    ProcessorCore i7 8700K 4.7avx 1.210v non-delid
    Memory (part number)G.Skill Trident Z RGB F4-3200C14D-32GTZR
    Graphics Card #1Asus ROG STRIX-GTX1070-8G-GAMING
    Sound CardSound Blaster Z
    MonitorSamsung 32inch 1080p
    Storage #1Samsung 970 pro 500gb
    Storage #2Samsung 970 evo plus 500gb 850 pro 128gb x2 + WD 8tb
    CPU CoolerCorsair H110i gt
    CaseCorsair Graphite 780T
    Power SupplyCorsair AX860 Platinum
    Keyboard Corsair K70 RGB LUX
    Mouse Logitech G pro
    OS Windows 10 pro 1909
    Accessory #1 Microsoft Xbox One Controller
    kens30's Avatar
    Join Date
    Jan 2018
    Reputation
    47
    Posts
    71

    Quote Originally Posted by mrvortep View Post
    Mine stays at x2 even if I manually change the setting to X4 - if I go back into the BIOS after a reboot it is back to X2 every time. This happens whether I set the first option to Auto or PCIe. What could this possibly be the result of...?!


    That said, if I run Samsung Magician, it says the Interface is "PCIe Gen. 3 x 4".
    This is normal behavior, in bios M.2-1 refers to your primary M.2 slot and M.2-2 to the second slot.
    If you have your m.2 drive installed in the first slot on your motherboard, in bios select pci-e mode for M.2-1 to get PCIe Gen. 3 x 4.

    The M.2-2 PCIe Bandwidth Control is for the second M.2 slot on the board, it always stays at x2 mode by default and does not affect the speed of your first slot.
    Only if a drive is connected on that secondary slot and supports pci-e x4 you can change the value to x4 mode without it reverting to x2 mode.

    And by the way the M.2 drives get their lanes from the chipset so your gpu will still run in full pci-e .3 x16 mode.

  10. #10
    ROG Enthusiast Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    51

    Quote Originally Posted by kens30 View Post
    This is normal behavior, in bios M.2-1 refers to your primary M.2 slot and M.2-2 to the second slot.
    If you have your m.2 drive installed in the first slot on your motherboard, in bios select pci-e mode for M.2-1 to get PCIe Gen. 3 x 4.

    The M.2-2 PCIe Bandwidth Control is for the second M.2 slot on the board, it always stays at x2 mode by default and does not affect the speed of your first slot.
    Only if a drive is connected on that secondary slot and supports pci-e x4 you can change the value to x4 mode without it reverting to x2 mode.

    And by the way the M.2 drives get their lanes from the chipset so your gpu will still run in full pci-e .3 x16 mode.
    Thank you, that's very clear!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •