Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    New ROGer Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    4

    My i9-7960X temps seems high after delidding

    Hi guys,

    I just want to know if my delid temps are normal or not because after delidding, everytime I run cinebench R15 I noticed that some of the core are hitting 82-93C while some of the core are only hitting around 74-80C. I used Thermal Grizzly Conductonaut between the CPU Die and IHS while Thermal Grizzly Kryonaut between the IHS and Monoblock. I don't know if everything is normal so I just need some suggestions from you guys Thanks

    BTW here are my PC Specs
    Case: Corsair 900D
    CPU: i9-7960X @4.7GHZ
    Motherboard: Rampage Vi Extreme
    GPU: 3 X Titan Xp
    Ram: Corsair Vengeance RGB @3466MHZ 16-18-18-36-2T (XMP On but I increased the frequency to 3733MHZ without adjusting the timings)
    PSU: EVGA 1600W P2
    Cooling: I got custom loop with a 2X480mm rad, 1X240mm rad and 1X120mm rad
    Pump: Koolance PMP-600 D5 pump
    Fans: Corsair Magnetic Levitation Fan color blue

    Here are my Overclock Settings
    Cpu Frequency: 4.7GHZ
    Cpu Core Voltage: 1.240V
    Cpu Cache: 3GHZ
    Cpu Cache Voltage: 1.170
    Both AVX negative Offset are set to: 2
    CPU Input Voltage: 1.950V
    Cpu Load line calibration: Level 4
    CPU Current Capability: 200%
    VRM Spread Spectrum: Disabled
    Cpu power Duty Control: Extreme
    Cpu power Phase control: Extreme
    Miniatura de Adjuntos Miniatura de Adjuntos Temps.jpg  


  2. #2
    Administrator Array Silent Scone@ROG's Avatar
    Join Date
    Mar 2016
    Reputation
    166
    Posts
    2,106

    That is high for post delid, although CR15 does pull a reasonable amount of current. You can re-check the cooler mounting, but beyond that, unfortunately, it's likely you'll have to take the lid off once again.

  3. #3
    ROG Guru: Yellow Belt Array Mr. Fox PC Specs
    Mr. Fox PC Specs
    Laptop (Model)- NA -
    MotherboardEVGA Z490 Dark K|NGP|N
    Processori9-10900KF @ 5.6GHz
    Memory (part number)16GB Patriot Viper DDR4-4000 @ 4600
    Graphics Card #1EVGA RTX 3090 K|NGP|N
    MonitorPredator XB271HU 2560x1440 165Hz
    Storage #1512GB 970 EVO x 2 (OS Boot Drives)
    Storage #2960GB Samung Enterprise NVMe SSD x 2 | 2TB HDD
    CPU CoolerMO_RA 360 Radiator +1/2 HP Water Chiller
    CasePraxis WetBench
    Power SupplyEVGA SuperNOVA P2 1600W
    Keyboard Corsair K95 RGB
    Mouse SteelSeries Sensei Wireless
    Headset Skullcandy Crusher Wireless S6CRW
    Mouse Pad Black Anodized Aluminum
    Headset/Speakers Logitech Z506 5.1 Speaker System
    OS W10 Ent LTSC 2019 / W7 Ultimate (Dual Boot)
    Accessory #1 Hailea HC-500A 1/2HP~790Watt Water Chiller
    Mr. Fox's Avatar
    Join Date
    May 2018
    Reputation
    41
    Posts
    127

    How do the temps compare to before you delidded? Are they greatly improved? Did you have the same variance in temperatures between cores before? Without know that, it is hard to say if the temps are high or not because it is all relative. The max on some cores is clearly higher than desirable.

    Did you glue the IHS back on? If not, lift it off and have another look at the liquid metal. Sometimes it doesn't stick well and tries to bead up, especially if the IHS or die has any oily surface contamination that was not fully removed during cleaning. There could be a couple of spots where it didn't make good contact, and that can cause the core variance. I always apply it to both surfaces so they come together wet, and that works better for me than applying it to one surface.

    I would expect lower temps if you are using all of those radiators for the CPU, or even one 480mm radiator for the CPU. Is the system being used in a cool environment?
    Last edited by Mr. Fox; 08-22-2018 at 01:53 PM.
    WRAITH // EVGA Z490 Dark K|NGP|N | Core i9-10900KF @ 5.6GHz | Optimus Signature Water Block on Bare Die | EVGA RTX 3090 K|NGP|N | 16GB Patriot Viper 4 Blackout DDR4 @ 4600 | EVGA SuperNOVA 1600 P2 | Hailea HC-500A (1/2HP~790W) Chiller | MO-RA3 360 Pro Radiator | Dual XSPC Photon 270 | Windows 7 Ultimate > Windows 10 Enterprise LTSC 2019 > Windows 10 Enterprise 2004 Cancer Edition > Linux Mint

  4. #4
    Administrator Array Silent Scone@ROG's Avatar
    Join Date
    Mar 2016
    Reputation
    166
    Posts
    2,106

    The op states he has a custom loop with multiple rads on a D5 pump, so that shouldn't be a problem.

  5. #5
    New ROGer Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    4

    I didn’t test the cpu temps before I delidded. Because the time when my cpu arrived, I delidded it right away.
    I didn’t reseal the ihs, i just let the monoblock hold the cpu.

    I put liquid metal between the bottom ihs and cpu die.

  6. #6
    Administrator Array Silent Scone@ROG's Avatar
    Join Date
    Mar 2016
    Reputation
    166
    Posts
    2,106

    Quote Originally Posted by sherick02 View Post
    I didn’t test the cpu temps before I delidded. Because the time when my cpu arrived, I delidded it right away.
    I didn’t reseal the ihs, i just let the monoblock hold the cpu.

    I put liquid metal between the bottom ihs and cpu die.
    In that case, remove the monoblock and attempt to reseat the IHS, closing the socket clamp once again and remount. Ideally, you should have tested the CPU before delidding.

  7. #7
    ROG Guru: Yellow Belt Array Mr. Fox PC Specs
    Mr. Fox PC Specs
    Laptop (Model)- NA -
    MotherboardEVGA Z490 Dark K|NGP|N
    Processori9-10900KF @ 5.6GHz
    Memory (part number)16GB Patriot Viper DDR4-4000 @ 4600
    Graphics Card #1EVGA RTX 3090 K|NGP|N
    MonitorPredator XB271HU 2560x1440 165Hz
    Storage #1512GB 970 EVO x 2 (OS Boot Drives)
    Storage #2960GB Samung Enterprise NVMe SSD x 2 | 2TB HDD
    CPU CoolerMO_RA 360 Radiator +1/2 HP Water Chiller
    CasePraxis WetBench
    Power SupplyEVGA SuperNOVA P2 1600W
    Keyboard Corsair K95 RGB
    Mouse SteelSeries Sensei Wireless
    Headset Skullcandy Crusher Wireless S6CRW
    Mouse Pad Black Anodized Aluminum
    Headset/Speakers Logitech Z506 5.1 Speaker System
    OS W10 Ent LTSC 2019 / W7 Ultimate (Dual Boot)
    Accessory #1 Hailea HC-500A 1/2HP~790Watt Water Chiller
    Mr. Fox's Avatar
    Join Date
    May 2018
    Reputation
    41
    Posts
    127

    Quote Originally Posted by sherick02 View Post
    I didn’t test the cpu temps before I delidded. Because the time when my cpu arrived, I delidded it right away.
    I didn’t reseal the ihs, i just let the monoblock hold the cpu.

    I put liquid metal between the bottom ihs and cpu die.
    What are your ambient temperatures? Is the room cool or hot?

    You may need to recheck the liquid metal application to be sure it is applied smoothly and evenly, and did not bead up or separate as previously mentioned. Apply it to both mating surfaces so the two halves come together wet. If you only put it on the die, look at the IHS when you lift it off. If there are any dry or bare spots where the die makes contact, that is the issue (not making good enough contact for thermal transfer).
    WRAITH // EVGA Z490 Dark K|NGP|N | Core i9-10900KF @ 5.6GHz | Optimus Signature Water Block on Bare Die | EVGA RTX 3090 K|NGP|N | 16GB Patriot Viper 4 Blackout DDR4 @ 4600 | EVGA SuperNOVA 1600 P2 | Hailea HC-500A (1/2HP~790W) Chiller | MO-RA3 360 Pro Radiator | Dual XSPC Photon 270 | Windows 7 Ultimate > Windows 10 Enterprise LTSC 2019 > Windows 10 Enterprise 2004 Cancer Edition > Linux Mint

  8. #8
    New ROGer Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    4

    Quote Originally Posted by Silent Scone View Post
    In that case, remove the monoblock and attempt to reseat the IHS, closing the socket clamp once again and remount. Ideally, you should have tested the CPU before delidding.
    Ohh okay I'll try to reseat the IHS this weekend. But do you think is it necessary to reglue the ihs? Because I've seen GamersNexus review and he showed that if you reglue the ihs, it ended up with higher cpu temps.

  9. #9
    New ROGer Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    4

    Quote Originally Posted by mr_fox_rox View Post
    What are your ambient temperatures? Is the room cool or hot?

    You may need to recheck the liquid metal application to be sure it is applied smoothly and evenly, and did not bead up or separate as previously mentioned. Apply it to both mating surfaces so the two halves come together wet. If you only put it on the die, look at the IHS when you lift it off. If there are any dry or bare spots where the die makes contact, that is the issue (not making good enough contact for thermal transfer).
    My room temperature right now is around 25-27C (Air conditioner turned on). Fan running at round 40% when IDLE. I have applied both surface with liquid metal.

    Im also afraid that there are some air trap inside the monoblock resulting in higher temps.

    Here's the sample pic of my pc:
    Miniatura de Adjuntos Miniatura de Adjuntos 39799583_1896939720603056_3068440231012204544_n.jpg  


  10. #10
    ROG Guru: Yellow Belt Array Mr. Fox PC Specs
    Mr. Fox PC Specs
    Laptop (Model)- NA -
    MotherboardEVGA Z490 Dark K|NGP|N
    Processori9-10900KF @ 5.6GHz
    Memory (part number)16GB Patriot Viper DDR4-4000 @ 4600
    Graphics Card #1EVGA RTX 3090 K|NGP|N
    MonitorPredator XB271HU 2560x1440 165Hz
    Storage #1512GB 970 EVO x 2 (OS Boot Drives)
    Storage #2960GB Samung Enterprise NVMe SSD x 2 | 2TB HDD
    CPU CoolerMO_RA 360 Radiator +1/2 HP Water Chiller
    CasePraxis WetBench
    Power SupplyEVGA SuperNOVA P2 1600W
    Keyboard Corsair K95 RGB
    Mouse SteelSeries Sensei Wireless
    Headset Skullcandy Crusher Wireless S6CRW
    Mouse Pad Black Anodized Aluminum
    Headset/Speakers Logitech Z506 5.1 Speaker System
    OS W10 Ent LTSC 2019 / W7 Ultimate (Dual Boot)
    Accessory #1 Hailea HC-500A 1/2HP~790Watt Water Chiller
    Mr. Fox's Avatar
    Join Date
    May 2018
    Reputation
    41
    Posts
    127

    That is possible. Do you have a different water block that you can test to see if that corrects the issue? Perhaps the monoblock is not fitting correctly.
    WRAITH // EVGA Z490 Dark K|NGP|N | Core i9-10900KF @ 5.6GHz | Optimus Signature Water Block on Bare Die | EVGA RTX 3090 K|NGP|N | 16GB Patriot Viper 4 Blackout DDR4 @ 4600 | EVGA SuperNOVA 1600 P2 | Hailea HC-500A (1/2HP~790W) Chiller | MO-RA3 360 Pro Radiator | Dual XSPC Photon 270 | Windows 7 Ultimate > Windows 10 Enterprise LTSC 2019 > Windows 10 Enterprise 2004 Cancer Edition > Linux Mint

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •