Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    ROG Member Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    9

    G752VS stuck at rog logo

    everytime i do a restart it always stuck at rog logo no problems if i do shutdown

  2. #2
    ROG Guru: Orange Belt Array
    Join Date
    Nov 2012
    Reputation
    55
    Posts
    393

    Reseat your memory sticks.

  3. #3
    ROG Guru: Brown Belt Array Darnassus PC Specs
    Darnassus PC Specs
    Laptop (Model)G752VS -=-=- G750JX
    MotherboardASUSTeK COMPUTER INC. G752VS (U3E1) -=-=- ASUSTeK COMPUTER INC. G750JX (SOCKET 0)
    Processori7 6700HQ @ 2.60GHz -=-=- i7-4700HQ CPU @ 2.40GHz - 3.40GHz
    Memory (part number)2x16gb (M471A2K43BB1-CRC) -=-=- 2x8gb (HMT41GS6AFR8A-PB)
    Graphics Card #1GTX 1070 (8GB) -=-=- GTX 770M (3GB)
    Sound CardRealtek High Definition Audio / NVIDIA High Definition Audio
    MonitorGSync IPS 75HZ -=-=- Chi Mei 60Hz (Overclocked to 85Hz)
    Storage #1Samsung SSD 960 EVO 250GB x2 -=-=- LITEONIT LCS-256M6S
    Storage #2HGST HTS721010A9E630 -=-=- ST1000LM024 HN-M101MBB
    CPU CoolerStock -=-=- Stock
    CaseStock -=-=- Stock
    Power SupplyStock -=-=- Stock
    Keyboard Stock -=-=- Stock
    Mouse Razer Naga Epic 1st Generation
    Headset SPH 2500
    Mouse Pad Razer Goliathus
    OS Winblows 10 Pro -=-=- Winblows 8.1 Pro
    Network RouterCG3000v2
    Darnassus's Avatar
    Join Date
    Dec 2013
    Reputation
    61
    Posts
    1,634

    Reinstall Win10 ;x
    Gosh Blue Lady.. ❤

    JOIN THE ASUS T-SHOOT DISCORD <-- Clicky!

  4. #4
    ROG Member Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    9

    Quote Originally Posted by Darnassus View Post
    Reinstall Win10 ;x
    i've already done it still the same everytime i restart or the system restart it just stuck at logo

  5. #5
    ROG Member Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    9

    Quote Originally Posted by jdfrench3 View Post
    Reseat your memory sticks.
    i only have 1 16gb ram and it is located underneath the kb so i need to disassemble the laptop

  6. #6
    ROG Guru: Orange Belt Array
    Join Date
    Nov 2012
    Reputation
    55
    Posts
    393

    When you reinstalled Win 10, did you use the drivers/programs located in your eSupport folder?

    Have you allowed Windows to upgrade itself? Any problems with that procedure?

    What is exact model G752VS?

  7. #7
    ROG Member Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    9

    Quote Originally Posted by jdfrench3 View Post
    When you reinstalled Win 10, did you use the drivers/programs located in your eSupport folder?

    Have you allowed Windows to upgrade itself? Any problems with that procedure?

    What is exact model G752VS?
    yes, i do backup the esupport folder and that is the one i am using except on the nvidia driver that i downloaded on nvidia site. i tried upgrading from 1709 to 1803 via windows update and tried clean installing 1803 but then after the installation if i go reboot it is just stuck on rog logo. btw it's
    g752vs - rb71

  8. #8
    ROG Guru: White Belt Array
    Join Date
    Nov 2015
    Reputation
    8
    Posts
    76

    If resitting does not help check if the sticks are matched pair( close serial numbers), if they are, maybe one failed. Check them with memtest86.

  9. #9
    ROG Guru: Orange Belt Array
    Join Date
    Nov 2012
    Reputation
    55
    Posts
    393

    Look in Device Manager, are there any drivers with problems?

    Have you tried to update any drivers with newer drivers from ASUS support website?

    What version Bios are you running? The latest is version 310.

    Have you uninstalled all programs except for Windows 10?

    In Task Manager, is there any task taking a lot of resources? Check this before you restart.

  10. #10
    ROG Guru: Brown Belt Array Darnassus PC Specs
    Darnassus PC Specs
    Laptop (Model)G752VS -=-=- G750JX
    MotherboardASUSTeK COMPUTER INC. G752VS (U3E1) -=-=- ASUSTeK COMPUTER INC. G750JX (SOCKET 0)
    Processori7 6700HQ @ 2.60GHz -=-=- i7-4700HQ CPU @ 2.40GHz - 3.40GHz
    Memory (part number)2x16gb (M471A2K43BB1-CRC) -=-=- 2x8gb (HMT41GS6AFR8A-PB)
    Graphics Card #1GTX 1070 (8GB) -=-=- GTX 770M (3GB)
    Sound CardRealtek High Definition Audio / NVIDIA High Definition Audio
    MonitorGSync IPS 75HZ -=-=- Chi Mei 60Hz (Overclocked to 85Hz)
    Storage #1Samsung SSD 960 EVO 250GB x2 -=-=- LITEONIT LCS-256M6S
    Storage #2HGST HTS721010A9E630 -=-=- ST1000LM024 HN-M101MBB
    CPU CoolerStock -=-=- Stock
    CaseStock -=-=- Stock
    Power SupplyStock -=-=- Stock
    Keyboard Stock -=-=- Stock
    Mouse Razer Naga Epic 1st Generation
    Headset SPH 2500
    Mouse Pad Razer Goliathus
    OS Winblows 10 Pro -=-=- Winblows 8.1 Pro
    Network RouterCG3000v2
    Darnassus's Avatar
    Join Date
    Dec 2013
    Reputation
    61
    Posts
    1,634

    If fresh install and ROG Logo still stuck,

    Disable Fast Boot. ;d
    Gosh Blue Lady.. ❤

    JOIN THE ASUS T-SHOOT DISCORD <-- Clicky!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •