Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    New ROGer Array p1nkmeth PC Specs
    p1nkmeth PC Specs
    Laptop (Model)GL504GM
    MotherboardAsus
    Processori7-8750H
    Memory (part number)16GB
    Graphics Card #1GTX 1060
    Storage #1HDD
    Storage #2SSD
    OS Win 10 N

    Join Date
    Aug 2018
    Reputation
    10
    Posts
    4

    GL504GM Problem!@ Stuttering,constant FPS drops etc.

    Hello! Thats my first Asus ROG laptop( GL504GM , i7-8750h + GTX 1060 + 16GB RAM) and i have few problems that i encounter and cannot find a fix for them.
    From few days im trying to figure it out,why im getting that nasty FPS drops when i play lets say GTA or BF1 on Medium or High settings,currently using Intel XTU to monitor my temps, well they are pretty good ( 71-75, no power Power limit throttling, no Thermal Throttling). When i start the game, first 10 minutes are okay but after that my FPS goes down from 90 to 25 for few seconds and goes back to 90 , and this every half a minute.As far as i see from Intel XTU, CPU and GPU are not overheating or someting,not sure whats happening.Tried Overclocking,reinstall drivers, reinstall clean Windows,changing power plans, max perfomance from 100% to 99% etc. and the problem still persist.First i thought it may be the Intel Turbo Boost , disabled it from Throttestop and the thing still getting my fps down. I dont know what to do more. Any suggestions what could be ? Thanks in advance!
    Last edited by p1nkmeth; 09-17-2018 at 06:06 PM.

  2. #2
    ROG Guru: Orange Belt Array FULLMETALJACKET7's Avatar
    Join Date
    Mar 2018
    Reputation
    45
    Posts
    367

    Install MSI afterburner and monitor the temperatures in game with the OSD. Alt-tabbing will give you wrong readings. Also, keep an eye on the CPU/GPU usage when the spikes occur.

  3. #3
    New ROGer Array p1nkmeth PC Specs
    p1nkmeth PC Specs
    Laptop (Model)GL504GM
    MotherboardAsus
    Processori7-8750H
    Memory (part number)16GB
    Graphics Card #1GTX 1060
    Storage #1HDD
    Storage #2SSD
    OS Win 10 N

    Join Date
    Aug 2018
    Reputation
    10
    Posts
    4

    Okay, thanks. I have managed to fix my fps drops and stutters, changed my fans mode from Balanced to Noise and it fixed it. Not sure how is this related. Tested BF1 with Ultra settings and its keeping 70-75 fps without any drops.

  4. #4
    ROG Junior Member Array
    Join Date
    Oct 2018
    Reputation
    10
    Posts
    1

    Help

    Quote Originally Posted by p1nkmeth View Post
    Okay, thanks. I have managed to fix my fps drops and stutters, changed my fans mode from Balanced to Noise and it fixed it. Not sure how is this related. Tested BF1 with Ultra settings and its keeping 70-75 fps without any drops.
    anything else u do to fix this? have the same problem with the same laptop

  5. #5
    ROG Member Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    6

    Quote Originally Posted by p1nkmeth View Post
    Hello! Thats my first Asus ROG laptop( GL504GM , i7-8750h + GTX 1060 + 16GB RAM) and i have few problems that i encounter and cannot find a fix for them.
    From few days im trying to figure it out,why im getting that nasty FPS drops when i play lets say GTA or BF1 on Medium or High settings,currently using Intel XTU to monitor my temps, well they are pretty good ( 71-75, no power Power limit throttling, no Thermal Throttling). When i start the game, first 10 minutes are okay but after that my FPS goes down from 90 to 25 for few seconds and goes back to 90 , and this every half a minute.As far as i see from Intel XTU, CPU and GPU are not overheating or someting,not sure whats happening.Tried Overclocking,reinstall drivers, reinstall clean Windows,changing power plans, max perfomance from 100% to 99% etc. and the problem still persist.First i thought it may be the Intel Turbo Boost , disabled it from Throttestop and the thing still getting my fps down. I dont know what to do more. Any suggestions what could be ? Thanks in advance!
    Im getting the same issue but with games like Ghost Recon Wildlands and Prey. My GPU underclocks from 1405 Mhz to 1200 - 1300 Mhz. Can you check yours if this is the case ?

  6. #6
    New ROGer Array
    Join Date
    Sep 2018
    Reputation
    10
    Posts
    1

    I'm Having same problem, but mine max core Frequency only can go 1.89ghz

  7. #7
    ROG Junior Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    1

    Please check the BIOS version that it is currently installed on your device and try to install the latest one.

    Your product has pre-installed the ASUS utility WinFlash Version V3.2.2 that could be also downloaded from the below link

    https://dlcdnets.asus.com/pub/ASUS/n...064.1459757999

    In order to check if you have the latest BIOS version you have to connect the Notebook with the charger and the battery level is more than 50%.

    Then you have to download and unzip below file* on the “desktop

    ”Please “run” (double click on the icon) the utility WinFlash and load the already downloaded file.

    *BIOS Version 307
    https://www.dropbox.com/s/vgie6ip353...S.307.zip?dl=0

    Please find below the related instructions
    https://www.asus.com/us/support/FAQ/1008276/

  8. #8
    ROG Enthusiast Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    70

    Quote Originally Posted by Nickvassilakos View Post
    Please check the BIOS version that it is currently installed on your device and try to install the latest one.

    Your product has pre-installed the ASUS utility WinFlash Version V3.2.2 that could be also downloaded from the below link

    https://dlcdnets.asus.com/pub/ASUS/n...064.1459757999

    In order to check if you have the latest BIOS version you have to connect the Notebook with the charger and the battery level is more than 50%.

    Then you have to download and unzip below file* on the “desktop

    ”Please “run” (double click on the icon) the utility WinFlash and load the already downloaded file.

    *BIOS Version 307
    https://www.dropbox.com/s/vgie6ip353...S.307.zip?dl=0

    Please find below the related instructions
    https://www.asus.com/us/support/FAQ/1008276/
    is this version for hero 2? or scar 2?? and did this bios really help in removing fps drops on hero 2 unit?
    Last edited by Vsparda; 01-03-2019 at 11:14 PM.

  9. #9
    ROG Member Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    15

    Quote Originally Posted by Nickvassilakos View Post
    Please check the BIOS version that it is currently installed on your device and try to install the latest one.

    Your product has pre-installed the ASUS utility WinFlash Version V3.2.2 that could be also downloaded from the below link

    https://dlcdnets.asus.com/pub/ASUS/n...064.1459757999



    ”Please “run” (double click on the icon) the utility WinFlash and load the already downloaded file.

    *BIOS Version 307
    https://www.dropbox.com/s/vgie6ip353...S.307.zip?dl=0

    Please find below the related instructions
    https://www.asus.com/us/support/FAQ/1008276/
    hi, is the BIOS for the GL or GM? or is it interchangeable? i run the utility and it said that 304 is the latest for my GM (1060)

  10. #10
    ROG Enthusiast Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    26

    Quote Originally Posted by desuzarasu View Post
    hi, is the BIOS for the GL or GM? or is it interchangeable? i run the utility and it said that 304 is the latest for my GM (1060)
    The BIOS is for GM(1060). You can update under BIOS with a spare USB

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •