Page 3 of 3 FirstFirst 1 2 3
Results 21 to 22 of 22
  1. #21
    ROG Guru: White Belt Array
    Join Date
    Jul 2018
    Reputation
    11
    Posts
    120

    Guys please check my workaround on fixing this issue: https://rog.asus.com/forum/showthrea...867#post757867

    I've totally fixed this problem with a very simple thing.

  2. #22
    ROG Member Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    15

    for those with stuttering issues, try disabling the Nahimic Services (disabling, not deleting, as deleting it would just make Windows download it again)



    make sure you have Admin privileges, then type services at the start menu, it will give you an app called 'Services', open it, find the NahimicService, then disable it. (right click on it, click properties, stop the service, then above it, toggle the startup type to Disabled. hope it works for you guys as it did mine (mine went from a lag fest and stuttering at forza horizon 4, to a pretty much smooth 48 fps all settings on high)

    and yes, i already undervolt the computer too, but i find nuking the nahimic service yield great result.
    Last edited by desuzarasu; 04-28-2019 at 02:11 PM. Reason: fps

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •