Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    ROG Member Array
    Join Date
    Aug 2011

    Question USB 3.0 connection problems (USB 2.0 works, USB 3.0 only works sometimes)

    Model: ASUS G53SW-XA1
    OS: Win7 64 Bit fully updated
    Driver: Latest USB Fresco 3.0 driver from


    I have a 1TB USB 3.0 WD Passport.

    1) If I plug it into any of the USB 2.0 drives it works fine (at 2.0 speeds).

    2) If I plug any USB 2.0 device into my USB 3.0 port, they work fine as well.

    3) However, if I plug my USB 3.0 drive into my USB 3.0 port it works maybe 25% of the time. Sometimes a reboot fixes it and sometimes if I unplug and plug it back in a few times it works. When it works, it's full USB 3.0 speed and I am satisfied. However, it is often a chore to get it to connect and it has become very annoying.


    I have received a new USB 3.0 cord from WD for my Passport and I have the same issue.

    Unfortunately I do not own any other device with a USB 3.0 port or connector so I cannot try those at this time, but am working on it.

    I was hoping someone here might have had similar issues and could offer some ideas to fix it. Of course if it's my WD Passport that's faulty, it will have to be RMA'd but I can't confirm that so I'm going on the assumption that this is a driver issue of some sort.

    Thanks in advance.

  2. #2
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011


    I can not help you out with this issue (I don't have a 1TB USB 3.0 disk).

    But there is a thread here about one who can not boot into his notebook if the 1TB disk is plugged into the USB 3.0 port. (this thread here)

    Quote Originally Posted by JRd1st View Post
    I think there's a USB charging option in the BIOS - turn it on and see if that helps.

    BTW, Brian has gone to greener pastures. Pm MarshallR@asus, instead.
    See if there is a USB charging option in BIOS as JRd1st is mentioning and see if that helps
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  3. #3
    ROG Member Array
    Join Date
    Aug 2011

    I do not see any USB Charging option in the G53SW 203 (latest) BIOS.

    I am surprised by how plain vanilla the BIOS options are, actually.

  4. #4
    ROG Member Array
    Join Date
    Aug 2011

    Anyone else have thoughts on this? Am I the only one?

  5. #5
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011

    USB 3.0 drives failing on USB 3.0 ports are reported for many laptop brands - just google the issue. Some recommend getting a shorter cable. Some recommend getting a "Y" type cable that plugs into 2 USB ports, one for power and data, the other just for power.

    If I was experiencing this issue, I'd be tempted to try ThrottleStop as discussed in This has resolved USB disconnection issues on G73JW/JH systems, maybe it can help keep the voltage steady enough on a G53SW system to prevent failure. We'll never know unless someone trys it....
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  6. #6
    ROG Guru: Orange Belt Array
    Join Date
    Sep 2011

    is it maybe your cable?

    if the cord itself isn't usb 3.0 compatible you could be getting kicked down to 2.0 mode.
    __________________________________________________ ________________
    Quote Originally Posted by dstrakele View Post
    I just blow the flames out and keep playin'....

  7. #7
    ROG Member Array
    Join Date
    Aug 2011

    As I said in the original post, I have received a new cord from WD and the results are still the same.

    It is definitely compatible because, as stated, USB 3.0 speeds work fine when I can get it to connect. The problem is just getting the connection to open...only works about 25% of the time.

  8. #8

    Unhappy USB 3.0 Connection Issues

    I have this exact same issue with my G53SW. I have a WD Passport 1TB USB 3 hard disk (two of them actually). I can connect it to the blue USB 3 port and it opens fine, then just drops after a few minutes. Sometimes it stays connected for 5 minutes, 10 minutes, 30 seconds, totally intermittent. And like stated above, this same drive(s) plugged into any of the USB 2 ports, will stay connected for hours on end. Oh, and for further ammunition, these drives stay connected to the USB 3.0 ports on all my other systems. I hope there is a fix for this.

  9. #9
    ROG Member Array
    Join Date
    May 2012

    Arrow Windows 7 PROBLEM with USB 3.0

    Windows 7 PROBLEM with USB 3.0

    Platform: Dell Dimension 4550 3.06 Ghz P4 HT enabled
    Addonics Host Controller 2-Port USB 3.0 PCI Controller
    WD My Book Essential 1130 2TB USB 3.0/2.0 external drive
    Transcend JF700 USB 3.0 16GB flashdrive

    Operating Systems:

    Windows XP SP3 with NECEL-USB3-Host-Driver-10170-setup - works flawlessly

    Windows 7 Home Premium SP1 with RENESAS-USB3-Host-Driver-21281-setup - problematic
    Anything from 1 to 10 re-installations of USB 3.0 driver required for connection to take effect
    Once achieved, connection is solid, can backup etc BUT lost on restart - [Definitely NOT USB 2.0 performance, tested]

    Windows 8 Consumer Preview with Renesas USB 3.0 eXtensible Host Controller - 0096 (Microsoft) This driver is Native to WIN 8, when uninstalled , RE-installed automatically with 'Scan for Hardware Changes' or Restart
    Anything from 0 to 6 re-installations of USB 3.0 driver required for connection to take effect
    Once achieved, connection is solid, can backup etc BUT lost on restart - [Definitely NOT USB 2.0 performance, tested]

    OBJECT: Demonstrate that problem lies with WIN 7 / WIN 8 - Once connected, that will let your Host Controller and USB 3.0 drivers off the hook


    A. Use USB 2.0 - Until the Windows 7 team get their fingers out, time lost trying to make USB 3.0 work, better used with that (slower) Backup.

    B: For those who want USB 3.0 to work and have the thrill of faster Access/BackUp
    1. TOOLS: (USB 3.0 Host Controller PCI/PCI-e in your machine)
    USB 3.0 Extention Cable (NOT 2.0) for ease of access(!)
    USB 3.0 HDD External Drive AND/OR Flashdrive- USB 3 AND/OR USB 2**

    ** Host Controller and Ext. Cable can also handle USB 2.0, USB 1.1 - Part of WIN 7 weirdness is when connected, on occasion, USB 2.0 Flash Drive NOT recognised (although connection sound, LED made) - Problem Not experienced with WIN 8 - Solution: Re-install driver - Step 2.(a)

    2.(a) INSTALL USB 3.0 Host Conroller Software/Drivers (see list below) - IF WIN 8 - not necessary
    IF ' [[Your Device is ready to Use] message not appear (WIN 7 only), re-install - Step 2.(a)
    TIP*** Locate Downloaded Driver (Application) with Explorer and 'Send Shortcut to Desktop' - you may have to repeat re-install x no.Times
    PLUG IN USB 3.0 Extension Cable (Otherwise you'll be on your knees, many,many times - unless it's a Laptop) to your USB 3.0 PORT

    (b) PLUG IN USB 3.0 OR USB 2.0 FlashDrive - LED flashing, staying On, b-boing on speakers? - Good - Autoplay Window up? (might not be enabled) so check My Computer - Drive shown as 'Removable Drive'? - SUCCESS

    3. ROUTINE for Multiple Attempts to coax WIN 7 into USB 3.0 connectivity:

    (a) Start/Control Panel/Hardware&Sound then OPEN Device Manager (leave open)

    (b) Expand - Universal Serial Bus Controllers - (bottom or near to)
    Locate - Renesas Electronics USB 3.0 Host Controller - (Ignore Root Hub)
    Right click - select - Uninstall - Ok (If you tick box for 'delete driver', you'll need to re-install drivers) Step 2.(a)

    REMOVE Flash Drive and/or External HDD

    (c) Device Manager - Action (pull down menu) - Click on 'Update Driver Software..' / 'Scan for Hardware Changes'
    What you want to see: [installing Device Driver Software] (Not shown WIN8)
    Then: [Your Device is ready to Use] Good, but no guarantee of success - failure message? Repeat Step 3.(b)
    PLUG IN Flash Drive and/or External HDD - Connection? then - (see Step 2.(b))
    IF NOT - REPEAT Step 3.(b) (As many times as you can bear, my limit - 10 times per session) ( 6 times for WIN 8)
    (IF you're getting nowhere , re-install driver - Step 2.(a)

    USB 3.00 Host Controller Software/Drivers tried on this Platform:
    USB3.0_allOS_2.1.28.1_PV (from Intel!)


    This is a controversial topic, only in the sense that searches reveal many users with this problem and apparent silence from Microsoft (not slagging off, I am a fan)
    For Example: Microsoft Answers yields zilch for 'USB 3.0' search

    The fact that Microsoft are now collaborating with Renesas (was NEC) on WIN 8 Native
    Renesas USB 3.0 eXtensible Host Controller - 0096 driver means that it should work and
    any solution applied to WIN 7.

    This cannot be a priority for Microsoft, only gentle pressure from users might help.

    PROBLEM: Some Installations with WIN 7 don't encounter USB 3.0 bug, so:
    BLAME: MOTHERBOARD / BIOS [Old PC after all] OR
    Host Controller Hardware Card / Firmware OR
    Host Controller Software/Drivers OR
    CHIPSET [ Ivy Brridge etc. - That leaves us far behind]

    MY ARGUMENT and Simple Logic is:

    IF USB 3.0 works flawlessly with WINDOWS XP
    THEN Installations of WIN 7 and WIN 8 on the same Platform (Same Hardware),
    which exhibit no other problems and are perfeclly stable, should work.
    Once connection is established, USB 3.0 works flawlessly - no breaks or drops [Definitely NOT USB 2.0 performance, tested]

    There are enough clues above, for someone knowledgable to push the envelope along,

    Putting it simply, WIN 7 / 8 are 'weak' in STARTING process even though Device Manager reports 'This device is working properly.'
    It might reside at the Boot/Logon stage

    That's all folks

    PS. What ever you do, don't mention the CHIPSET, I mentioned it once but i think i got away with it...
    Last edited by zirc99; 05-07-2012 at 05:30 PM.

  10. #10
    ROG Enthusiast Array Here4Help's Avatar
    Join Date
    Jun 2012

    Hi, I have the exact same problem, my WD 3.0 1TB drive only connects sometimes. All my 2.0 flash drives work with no problem. I tried updating the drivers but no luck. It takes 6 tries sometimes. I was not able to find a fix yet. I am rerunning my unit as I have a defective HDMI port/flickering screen as well.

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts