Results 1 to 10 of 12

Threaded View

  1. #1
    ROG Member Array ATLANTICA_NFS's Avatar
    Join Date
    Jun 2017
    Reputation
    10
    Posts
    22

    GL502VMK - TPM not available after BIOS-downgrade / upgrade -solved

    Hi everyone,

    So I updated to BIOS Version 305 the other day - worked perfectly fine.
    Today, I downgraded to BIOS Version 302 to check-out performance-changes etc., upgraded 'back' to BIOS Version 305 after like 30 minutes - again, no errors etc.

    Once booted-up, I did notice a change regarding BitLocker / TPM-availability: The OS couldn't access the TPM-chip anymore, BitLocker is unable to resume.

    I did check the BIOS-settings - TPM is active.
    Cleared/ re-installed the factory-keys / re-tried a BIOS-down- / upgrade - without success...

    The TPM was listed in the device-manager for like 5 minutes - as a hidden device - only to disappear again.

    Drained the battery completely, hoping this 'power-cycle' might re-enable the TPM - again, to no avail.


    Would anybody have an idea if / how this issue could be fixed?

    Thank you in advance + best regards

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •