Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    ROG Member Array
    Join Date
    Nov 2018

    ASUS EZ UPDATE Software not updating drivers

    I keep getting this thing called EZ Update popping in my screen telling me that I have a new update. I click Connect and the EZ Update tells me that there is a new update called ( Intel Chipset driver . The current version of the Intel Chipset driver that I have install in my computer is version . Here is the problem every time I hit the Update button EZ Update acts like it is updating to the latest version and even tells me after supposedly finishing installing the latest version of the driver, it tells me that the updates has finished. I close EZ update and go and check and i'm still stuck with version and not version EZ update did nothing and never updated to the latest driver version and in top of that EZ update keeps popping in my screen telling me that I have an update but every time I try to update it never updates to the latest version

  2. #2
    ROG Junior Member Array lazyd PC Specs
    lazyd PC Specs
    MotherboardMaximus XI Hero
    Processori7 8700K
    Memory (part number)F4-3200C16D-16GVKB
    Graphics Card #1EVGA RTX 2080 Ti Black
    Sound CardSoundBlaster Z
    MonitorAOC AG322QWG4
    Storage #1Samsung 970 Evo NVMe
    CPU CoolerKraken X62
    CasePhanteks Enthoo Pro M TG
    Power SupplyCorsair AX860
    Keyboard Corsair K70
    Mouse Logitech G703
    Headset HyperX Cloud Alpha
    OS Windows 10 Pro
    lazyd's Avatar
    Join Date
    Oct 2018

    In my case it says I have 3 updates but doesn't show the updates

  3. #3
    New ROGer Array Wangeyed PC Specs
    Wangeyed PC Specs
    MotherboardROG STRIX Z390-F
    Processori5 9600K
    Graphics Card #11080 ti

    Join Date
    Nov 2018

    Quote Originally Posted by lazyd View Post
    In my case it says I have 3 updates but doesn't show the updates
    same problem here

  4. #4
    ROG Guru: White Belt Array jewie27 PC Specs
    jewie27 PC Specs
    Laptop (Model)Asus ROG G50 VT
    MotherboardAsus ROG Maximus XI Hero Wi-Fi
    ProcessorIntel I9-9900K
    Memory (part number)Corsair Vengeance Pro DDR4 3200 Mhz CL16
    Graphics Card #1EVGA RTX 2070 XC Ultra
    Sound CardOn -board Supreme FX
    MonitorAsus ROG Swift PG279Q - 27 Inch, 1440P, 165 Hz
    Storage #1Samsung 970 Evo M.2 NVME 1TB
    Storage #2Seagate Firecuda 2TB Hybrid SSHD
    CPU CoolerCorsair H100i V2
    CaseCorsair Graphite 600T
    Power SupplyCorsair AX1200 - 1200 watt Gold rated
    Keyboard Corsair Strafe RGB
    Mouse Razer Imperator 2012 BF3 Edition
    Headset Corsair Vengeance Headset
    Mouse Pad Razer Scarab Battlefield 3 Edition
    Headset/Speakers Corsair SP250
    OS Windows 10 64-Bit OEM
    Network RouterLinksys WRT-3200 Wireless AC
    Accessory #1 Asus ROG RGB LED Light strip
    Accessory #2 Vantec USB 3.0 Internal Header add-on card
    Accessory #3 NZXT Internal USB 2.0 Expansion Hub (+5 ports)
    jewie27's Avatar
    Join Date
    Mar 2011

    same. any solutions?
    New ROG PC built Nov 2011:
    Asus Maximus IV Extreme-Z
    Intel Core I5-2500K
    (2) EVGA GTX 580 Superclocked in SLI
    Corsair 600T
    Corsair H100 Liquid CPU Cooling
    Corsair AX1200 PSU
    Corsair Force 3 128GB SSD for boot drive
    8GB Red Corsair Vengeance @ 1600 Mhz 9-9-9-24
    1.5 TB Western Digital Caviar Black
    Asus 12x Blu-Ray Writer

    Built my first PC at age 12, Pentium III @ 450 Mhz.

  5. #5
    ROG Guru: Orange Belt Array
    Join Date
    Dec 2017

    The EZ Update software have never showed any updates for any system I had.. I literally have no idea how and when it's supposed to work.

    I wish that ASUS would strongly utilize this utility to easily update every firmware/driver/software.. and not force us to manually install updates under absurd procedures (using removal tools)

    Meh who am I kidding, it's never gonna happen.

  6. #6
    ROG Enthusiast Array
    Join Date
    Nov 2018

    mine says updates are available but yet none are on the list..cant click on anything

  7. #7
    Banned Array JustinThyme PC Specs
    JustinThyme PC Specs
    Laptop (Model)G752VY-DH72
    MotherboardRampage VI Extreme
    ProcessorI9 9940X
    Memory (part number)64GB DDR4 8x8 Corsair Dominator Platinum 3800 MHz @ C17
    Graphics Card #1ASUS Strix 2080Ti O11G @ 2.1GHz
    Graphics Card #2ASUS Strix 2080Ti O11G @ 2.1Ghz
    Graphics Card #3ROG Nvlink
    Graphics Card #4Have to feed animals
    Sound CardExternal Audioengine D1 24 bit 192kbps DAC
    MonitorASUS PG348Q @ 100Hz
    Storage #1Intel 905P 480GB U2 flavor
    Storage #2Samsung 850 EVO 1TB X2 in RAID 0, 960 PRO 1TB DIMM.2_1
    CPU CoolerHeatKiller IV PRO and VRM blocks ,Dual D5 PWM serial, 2X 480, 1X 360 RADS
    CasePhanteks Enthoo Elite 8X LL120 PWM, 3X LL140 PWM, 12 SP120 PWM 1x AF140 PWM
    Power SupplyCorsair AX 1500i
    Keyboard ASUS Claymore
    Mouse ASUS Spatha, Logitech MX Master
    Headset Sennheiser HD 700
    Mouse Pad ASUS ROG Sheath
    Headset/Speakers Audioengine A5+ with SVS SB-1000 Sub
    OS Win10 Pro 1809
    Network RouterNetGear NightHawk X10
    Accessory #1 NetGear Prosafe 10GBe Switch
    Accessory #2 Qnap TVS-682 NAS modded with I7 CPU

    Join Date
    Nov 2013

    This has never worked for me. I just check now and then or any updates.

  8. #8
    ROG Member Array
    Join Date
    Jan 2018

    So they
    er just going to ignore this thread and not fix it? Are they going to tell us to use the asus grid service...yet still pump out ez update. This is all getting to be a little ridiculous. We pay a premium for ROG and one of the sell factors are the software we get for being members of the ROG...BS. Their software is junk and they know it...they're too busy making cell phones to fix their software for their dedicated members. Even their Armoury software for their mice and keyboards is junk. My ROG Spatha has needed a firmware update forever and the newest version refuses to recognise the fact. They know its doing this...yet still no fix. I have EVERYTHING ROG...including their new 144hz 4k panel, but I can only use half the software. I will definantly be going with MSI next build I do for some...or maybe Aorus line up. Shame on you ASUS for selling broken garbage half working software with your products and trying to convince us thats one of the reasons we pay the premium.

  9. #9
    ROG Guru: Yellow Belt Array Kronvict PC Specs
    Kronvict PC Specs
    Laptop (Model)MSI GT72 2QD Dominator
    ProcessorAMD Ryzen 7 2700X
    Memory (part number)16GB G.Skill Ripjaws X DDR4
    Graphics Card #1EVGA GTX 1080 FE
    Sound CardCreative Sound Blaster ZxR
    MonitorASUS ROG Swift PG278Q
    Storage #1Samsung EVO 500GB
    Storage #2WD Black 4TB
    CPU CoolerAsus ROG RYUO
    CaseCooler Master Cosmos II Ultra Tower
    Power SupplyCougar CMX 1000W
    Keyboard Corsair Vengence K70
    Mouse ASUS ROG GX1000
    Headset Beyerdynamic DT 990 Pro
    Mouse Pad Corsair Aluminum
    Headset/Speakers Corsair SP2500
    OS Windows 10 Pro X64
    Network RouterASUS RT-AC87U
    Kronvict's Avatar
    Join Date
    Oct 2011

    Been having this issue as well ever since i built my rig lol.

  10. #10
    ROG Enthusiast Array thr23 PC Specs
    thr23 PC Specs
    MotherboardAsus ROG Rampage VI Extreme
    ProcessorIntel Core i7-7820X
    Memory (part number)G.Skill Trident Z RGB DDR4, 4x16GB, 3600MHz (F4-3600C17Q-64GTZR)
    Graphics Card #1Asus ROG Strix GeForce GTX 1080 Ti OC
    Storage #1Samsung SSD 960 PRO 1TB
    Storage #2WD Red 10TB
    CPU CoolerNoctua NH-D9L
    CaseIn-Win 805 Red
    Power SupplyThermaltake Toughpower iRGB PLUS 1250W Titanium

    Join Date
    Oct 2017

    yeah, it simply doesn't do anything. just useless bloatware.

Page 1 of 3 1 2 3 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts