Results 1 to 9 of 9
  1. #1
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    3

    ROG Strix Flare Play/Pause button light

    Has anyone else had the Play/Pause button light stop working? The function of the button still works but the white light behind doesnt turn on. I have tried updating the firmware but makes no difference. Possibly this is a RMA?

  2. #2
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    102
    Posts
    1,532

    Was it working before? Any idea what happened when it suddenly stopped working?
    Are you on firmware 0.00.35 / Armoury 3.00.11?
    Please check your inbox, a link to the firmware has been sent. Please update again manually if necessary.

  3. #3
    ROG Junior Member Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    2

    i had the same problem, r u already fix it?

  4. #4
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    102
    Posts
    1,532

    Quote Originally Posted by BaimYahya View Post
    i had the same problem, r u already fix it?
    Please check your inbox, a link to the firmware has been sent. Please update again manually if necessary.

  5. #5
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    1

    Same problem

    Please send me also the manual update for the firmware. Thanks.

  6. #6
    New ROGer Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    2

    ROG Strix Flare Media Key RGB Lightning not working

    Mine also please send me a firmware thanks.
    Last edited by Verxsil; 02-08-2020 at 04:02 AM.

  7. #7
    New ROGer Array
    Join Date
    Dec 2019
    Reputation
    10
    Posts
    1

    same problem

    Please send it to me too, ive recently experience the same problem and now even the skip buttons are not lighting up

  8. #8
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    3

    Mine still dont work with the firmware, I tried to send me keyboard back but it got damaged in shipping to the retailer and the delivery company wont take responsibility. It still works but now has a crack in it.

  9. #9
    New ROGer Array
    Join Date
    Feb 2020
    Reputation
    10
    Posts
    1

    (Stop) and (Previous) media key lights not working

    I've got the same problem. Both the 'Stop' media button and the 'previous' media button gradually stopped working. I noticed that they got dimmer with each start up. Does the firmware help or is there another solution to this? Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •