Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    4

    Trouble with G703GI FN + F5 not working as usual

    Greetings all!

    Just needed some assistance in regards to the functionality of one key of my keyboard.

    I'm using a ASUS ROG G703GI Gaming laptop.

    Every single other button on the keyboard works as expected, including f5.
    The function button works for all other related functions, the other F buttons work as expected, there's no issue with the button itself.

    When I open up the ROG gaming centre, the fan overboost setting changes as expected when prompted by clicking the option, everything seems to run fine.
    This button was also working previously.

    One day I simply attempted to press it and it wouldn't automatically adjust the setting on it's own.

    I've looked up many possible fixes via the internet for enabling/disabling the function key, the f5 button, etc. But since it's related to only one button, in particular, I figured I'd post here in the hopes someone may have a possible solution.

    I know it's a very minor issue, but just hoping to keep the keyboard running as smoothly as possible without hindrance.

    Regards.
    Ryan.

    If screenshots of any settings will assist please feel free to ask.

  2. #2
    ROG Enthusiast Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    49

    I have the same issue, and i dont think that we are the only ones to come across this issue. i have not found any solutions yet. i even sent my laptop for rma and still came back with F5 not working

  3. #3
    ROG Enthusiast Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    49

    Anyone with a fix for this issue?

  4. #4
    ROG Guru: Blue Belt Array Gps3dx PC Specs
    Gps3dx PC Specs
    Laptop (Model)Current: G751JT | Retired: G55VW, G51JX
    MotherboardInc M.2 slot
    Storage #1Samsungs EVO 850 128GB
    Storage #21TB HGST Travelstar 7K1000 (HTS721010A9E630)
    CPU CoolerMother Nature & Thermodynamics laws
    Mouse Logitech MX 518
    Headset/Speakers Logitech T6060
    OS Cleaned installed Windows 10 HOME x64
    Accessory #1 Leap Motion

    Join Date
    Feb 2015
    Reputation
    71
    Posts
    768

    FN+F5 is screen brightness down or another function ( what ?) ?

    anywho - reinstall ATK driver or get latest one / prior to that etc....
    also, open device manager and make sure you've got drivers installed to all devices.

  5. #5
    ROG Enthusiast Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    49

    on the G703GI the f5 key is for overboost fan settings. i have tried uninstalling all drivers and reinstalling them but nothing has worked. i have even done a factory reset but this still has had no effect.

  6. #6
    ROG Guru: Orange Belt Array
    Join Date
    May 2011
    Reputation
    28
    Posts
    390

    Quote Originally Posted by evezy123 View Post
    on the G703GI the f5 key is for overboost fan settings. i have tried uninstalling all drivers and reinstalling them but nothing has worked. i have even done a factory reset but this still has had no effect.
    Just out of curiosity, are you guys getting the screen notification of the change or no? Have you also updated your Bios by chance?

    I ask because I have read about strange issues after Bios updates. I haven't done mine yet in fear that something may break.

    Click image for larger version. 

Name:	20181115_104549.jpg 
Views:	0 
Size:	193.8 KB 
ID:	77012

    Click image for larger version. 

Name:	20181115_104553.jpg 
Views:	1 
Size:	180.4 KB 
ID:	77013
    ALIENWARE R17 R5 - i7 8750H - GTX 1070 @ 1.9Ghz - 16GB DDR4 - NVMe 970 EVO 1TB - SSD 960 EVO 1TB
    SOLD: ASUS G703VI-XH74K
    RETIRED: ASUS G752VY-DH72
    RETIRED: ASUS G750JH DB71
    RETIRED:ASUS G74Sx DH72

  7. #7
    ROG Enthusiast Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    49

    MrRuckus when the buttons are pressed nothing appears on screen. It's as if the keys have not been pressed. I have done every type of uninstall and reinstall I can think of, to no avail

  8. #8
    ROG Guru: Blue Belt Array Gps3dx PC Specs
    Gps3dx PC Specs
    Laptop (Model)Current: G751JT | Retired: G55VW, G51JX
    MotherboardInc M.2 slot
    Storage #1Samsungs EVO 850 128GB
    Storage #21TB HGST Travelstar 7K1000 (HTS721010A9E630)
    CPU CoolerMother Nature & Thermodynamics laws
    Mouse Logitech MX 518
    Headset/Speakers Logitech T6060
    OS Cleaned installed Windows 10 HOME x64
    Accessory #1 Leap Motion

    Join Date
    Feb 2015
    Reputation
    71
    Posts
    768

    the image that appears when pressing FN+Fx is coming from ATK driver package from Asus.
    goto c:\Program Files (x86)\ASUS\ATK Package\ and look for a folder and/or EXE with OSD in its name... mine is "ATKOSD2\ATKOSD2.exe".
    if you don't have something like it there a good *POSSIBILITY* that you won't see any image when pressing these FN combo.

  9. #9
    ROG Enthusiast Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    49

    Quote Originally Posted by evezy123 View Post
    MrRuckus when the buttons are pressed nothing appears on screen. It's as if the keys have not been pressed. I have done every type of uninstall and reinstall I can think of, to no avail
    hi i have just checked and i dont have an ATK Folder at all

  10. #10
    ROG Enthusiast Array
    Join Date
    Jul 2014
    Reputation
    10
    Posts
    46

    Quote Originally Posted by MrRuckus View Post
    Just out of curiosity, are you guys getting the screen notification of the change or no? Have you also updated your Bios by chance?

    I ask because I have read about strange issues after Bios updates. I haven't done mine yet in fear that something may break.

    Click image for larger version. 

Name:	20181115_104549.jpg 
Views:	0 
Size:	193.8 KB 
ID:	77012

    Click image for larger version. 

Name:	20181115_104553.jpg 
Views:	1 
Size:	180.4 KB 
ID:	77013
    Our G703VI model has a totally different scenario. They have silent, balanced and boost mode, we have auto and overboost. *I updated my G703VI BIOS. No problem so far but no improvement as well at the fan profiles.

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •