Results 1 to 7 of 7
  1. #1
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Processor9900K
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011
    Reputation
    13
    Posts
    1,503

    ASUS Support page

    Good morning ASUS. Support page is down. I try since yesterday again.

    Bios and firmware is ok. But drivers and tools you select the os type, and there is NO results.

    I try 4 boards and 3 video cards and is the same

    Click image for larger version. 

Name:	asdfasdfasdfasdf.png 
Views:	2 
Size:	89.8 KB 
ID:	77026

  2. #2
    ROG Guru: Gold Belt Array Menthol PC Specs
    Menthol PC Specs
    MotherboardM 10 Apex / XI gene
    Processor8700K / 9900K
    Memory (part number)2x8 Gskill Trident Z 4266/2x2x8 Gskill Trident Z 4500
    Graphics Card #1RTX 2080ti / GTX 1060
    Sound CardSoundBlaster Ae5 / Onboard
    MonitorBENQ 32" 4K
    Storage #1Intel 900p 480GB/Samsung 960 Pro 1TB
    Storage #2Intel 750 1.2TB/Plextor 1 TB 2X 950 Pro
    CPU CoolerCorsair H150i AIO / H1110i
    CaseCorsair 740 ? Lian Li Air
    Power SupplyCorsair AX 1200i / AX 1200i
    Keyboard Corsair
    Mouse ASUS Strix
    Headset HyperX Cloud Alpha
    Mouse Pad ASUS
    Headset/Speakers Logitech Z906
    OS 10 X64 Pro
    Network RouterVerizon Fios
    Accessory #1 Intel Wifi BT pcie card
    Accessory #2 Red Bull
    Accessory #3 English Breakfast Tea
    Menthol's Avatar
    Join Date
    Jan 2012
    Reputation
    241
    Posts
    4,547

    I have had the same issue for some time know, but not for every board model

  3. #3
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Processor9900K
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011
    Reputation
    13
    Posts
    1,503

    Quote Originally Posted by Menthol View Post
    I have had the same issue for some time know, but not for every board model

    so far i test boards: z170/z270/z370 rog hero. GPU 1080ti/1080/1060

  4. #4
    ROG Guru: Grand Master Array HiVizMan's Avatar
    Join Date
    Dec 2011
    Reputation
    354
    Posts
    25,742

    I have had the same thing.

    I had to change browser to IE or Edge and then for some platforms change the country.

    Frustrating to say the least. Have bumped this up the ladder.
    To help us help you - please provide as much information about your system and the problem as possible.

  5. #5
    ROG Guru: Orange Belt Array
    Join Date
    Dec 2017
    Reputation
    12
    Posts
    311

    When I have this problem, usually a web browser cleanup resolves the issue, however frustrating it is..

  6. #6
    New ROGer Array Rush.'s Avatar
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    3

    you should visit the website through another country's version
    for example, search for your model on canadian or indian asus site
    worked for me

  7. #7
    ROG Enthusiast Array pokuly PC Specs
    pokuly PC Specs
    MotherboardASUS PRIME Z370-A
    ProcessorSpectre inside i7 8700k
    Memory (part number)G.Skill Trident Z F4-3200C14D-32GTZSW
    Graphics Card #1EVGA GTX 970 SC
    MonitorASUS VN279QLB@75Hz
    CPU CoolerThermalright Macho
    Power SupplySuperflower 550W

    Join Date
    Feb 2018
    Reputation
    10
    Posts
    69

    If i visit the driver page after i was at the ROG forum the ROG cookies seem to confuse the driver page. Deleting all cookies solves the prob in Firefox. I use the cookie autodelete add-on.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •