Results 1 to 6 of 6
  1. #1
    ROG Member Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    8

    rog Centurion 5.1 music side channel instead of rear ??

    hi , i notes when i play an 5.1 music dvd from jean micheal jarre, the rear channel is send to the side channel ??

    does anyone als have that to ?.

  2. #2
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Those channels are sometimes swapped by Dolby when using 5.1, this is not something we can change. If we swap them, then 7.1 will be messed up.

  3. #3
    ROG Member Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    8

    Quote Originally Posted by MasterC@ASUS View Post
    Those channels are sometimes swapped by Dolby when using 5.1, this is not something we can change. If we swap them, then 7.1 will be messed up.
    oh oke.. i have notes that this week on playing a micheal jarre dts 5.1 and was now on the rear channel. strange that they do this .

    and by the way.... i notes that the rog software looses contact with the rog unit .
    when i turn the volume up or down or the button from headset to speaker .. it is not responding.
    i have to exit it to fully shutdown en restart the program and works again ... and this happens often.

    2e i love the headset but is the really no option to do something about the ear pillows on the headset ?.. because after an half a n hour it starts hurdling my ears a lot and is very irritating..
    the ear is toughing the plastic because the pillow is not thick enough to get space between ear and the headset

  4. #4
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by johnnyxtheman View Post
    oh oke.. i have notes that this week on playing a micheal jarre dts 5.1 and was now on the rear channel. strange that they do this .

    and by the way.... i notes that the rog software looses contact with the rog unit .
    when i turn the volume up or down or the button from headset to speaker .. it is not responding.
    i have to exit it to fully shutdown en restart the program and works again ... and this happens often.

    2e i love the headset but is the really no option to do something about the ear pillows on the headset ?.. because after an half a n hour it starts hurdling my ears a lot and is very irritating..
    the ear is toughing the plastic because the pillow is not thick enough to get space between ear and the headset
    For the audio station, have you inserted both USB connectors into the PC?
    You can try the modified firmware also:
    https://rog.asus.com/forum/showthrea...er-amp-downmix

    For the fit, the only thing you can do is try swapping the protein leather and mesh cushions.

  5. #5
    ROG Member Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    8

    gaming sound disappears suddenly

    Quote Originally Posted by MasterC@ASUS View Post
    For the audio station, have you inserted both USB connectors into the PC?
    You can try the modified firmware also:
    https://rog.asus.com/forum/showthrea...er-amp-downmix

    For the fit, the only thing you can do is try swapping the protein leather and mesh cushions.
    it is oke now, i swapt the side/rear channel from my speaker setup . but what this has to do whit the headset i don't know but now 5.1 is now rear on rear channel. so somehow that solved it.

    but found an other problem while gaming.

    suddenly sound disappears but headset is still working oke.

    i went to the hardware on my pc , did a test there and the test bels of win 10 64b works fine (game is still running with no sound)
    als o played some music with kmplayer and is also oke. so somehow the game (prepar3D flight simulator ) looses connection while gaming.
    i have read more about this on other games in forums with the rog centurion.
    also have farcry 5 but have no problem there.

    some i read sound disappeard but comes back after a wile but on me it disappears and thats it, have to save game, restart game to get sound back until it disappears again.

  6. #6
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by johnnyxtheman View Post
    it is oke now, i swapt the side/rear channel from my speaker setup . but what this has to do whit the headset i don't know but now 5.1 is now rear on rear channel. so somehow that solved it.

    but found an other problem while gaming.

    suddenly sound disappears but headset is still working oke.

    i went to the hardware on my pc , did a test there and the test bels of win 10 64b works fine (game is still running with no sound)
    als o played some music with kmplayer and is also oke. so somehow the game (prepar3D flight simulator ) looses connection while gaming.
    i have read more about this on other games in forums with the rog centurion.
    also have farcry 5 but have no problem there.

    some i read sound disappeard but comes back after a wile but on me it disappears and thats it, have to save game, restart game to get sound back until it disappears again.
    If you are connecting speakers directly to the audio station, it is great when you want to switch between those speakers and the headset using the 'speakers' button. I would advise not to switch the rear and side channels because you'll have to switch again for different content and for 7.1 (will never be swapped). If you are having issues in only one game, then your best bet is to contact the game publisher directly for help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •