Results 1 to 1 of 1
  1. #1
    ROG Member Array
    Join Date
    Apr 2014

    ROG laptop booting into BIOS loop

    Hi everyone
    Yesterday I was cleaning my asus rog g750gz laptop with a paper towel and alcohol, all the laptop, some of the keyboard keys were really dirty so I cleaned them a bit hard and put a bit more emphasis on keyboard and palm rest. Before that my laptop was working fine I turned it off and after some time I did the cleaning and after finishing it the laptop boots only into BIOS, at first I tried to do discard changes and exit but it went into BIOS again, then I did the reset to default and save & exit changes still went to BIOS again, I did the CSM and secure boot solution too it went to reboot and select proper boot device, I also tried to go into windows restore after doing the CSM and secure boot thing but it doesnt work it still goes to the select proper boot device and I cant access the windows restore menu. I watched a video on YT were it showed this boot into BIOS loop problem could be caused by the key you press to go into BIOS being stuck, (something that makes sense considering the hard keyboard cleaning) so even if you arent pressing anything the computer goes into BIOS because it detects the BIOS key is stuck or damged, so I tired to removed these keys: Esc, F1, F2, F9, F10, F12 and Delete but only the Esc key had dirt below it, I ceaned all the key slots but still went into the BIOS loop. Lastly I wanna say this error happened to me before, I dont remeber well but probably was after the keyboard cleaning too, but the 1st time this happened it fixed by itself after 2 o 3 reboots but this time its stuck in this problem. Im attachig images of my BIOS hoping you can help my solve this problem.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts